Foros del Web » Programación web » PHP »

No se ven los acentos y ñ bien en rss

Estas en el tema de No se ven los acentos y ñ bien en rss en el foro de PHP en Foros del Web. Hola a todos/as, este es mi primer mensaje en el foro. He añadido un pequeño código en php para incluir noticias de una web externa ...
  #1 (permalink)  
Antiguo 20/11/2008, 07:54
 
Fecha de Ingreso: noviembre-2008
Mensajes: 24
Antigüedad: 5 años, 10 meses
Puntos: 0
No se ven los acentos y ñ bien en rss

Hola a todos/as,
este es mi primer mensaje en el foro.
He añadido un pequeño código en php para incluir noticias de una web externa en mi web usando readfile().
El código es el siguiente:
<? readfile('http://www.rss-info.com/rss2.php?integration=php&windowopen=1&rss=http%3A% 2F%2Fmeneame.net%2Frss2.php&number=4&width=200&ifb gcol=FFFFFF&bordercol=FFFFFF&textbgcol=FFFFFF&rssb gcol=FFFFFF&showrsstitle=0'); ?>
Las noticias las muestra, pero en lugar de las letras que contienen acentos y las ñ, muestra caracteres raros.
Sé que me falta codificar el texto que leo a ISO-8859-1, pero no sé como... Existe algún parámetro en readfile (charset o algo parecido) con el que lo pueda hacer?
La verdad es que le veo mala solución al tema...
Gracias!!
  #2 (permalink)  
Antiguo 20/11/2008, 08:07
Avatar de rogertm
Mod->Cuba
 
Fecha de Ingreso: julio-2005
Ubicación: /home/Cuba/Habana/rogertm/
Mensajes: 2.900
Antigüedad: 9 años, 2 meses
Puntos: 628
Respuesta: No se ven los acentos y ñ bien en rss

Verifica en tu codigo esta linea:
<meta http-equiv="content-type" content="text/html; charset=ISO-8859-1" />
eso esta dentro de la etiqueta <head> ...</head>

saludos y bienvenido a FDW
__________________
Friki y Blogger por Cuenta Propia:213
Twenty'em: Theming is Prose
  #3 (permalink)  
Antiguo 20/11/2008, 08:14
 
Fecha de Ingreso: noviembre-2008
Mensajes: 24
Antigüedad: 5 años, 10 meses
Puntos: 0
Respuesta: No se ven los acentos y ñ bien en rss

Hola rogertm,

este código sí que está en la web:
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
  #4 (permalink)  
Antiguo 20/11/2008, 08:17
Avatar de rogertm
Mod->Cuba
 
Fecha de Ingreso: julio-2005
Ubicación: /home/Cuba/Habana/rogertm/
Mensajes: 2.900
Antigüedad: 9 años, 2 meses
Puntos: 628
Respuesta: No se ven los acentos y ñ bien en rss

Cámbialo a UTF-8 a ver si no te da mas errores
__________________
Friki y Blogger por Cuenta Propia:213
Twenty'em: Theming is Prose
  #5 (permalink)  
Antiguo 20/11/2008, 08:38
 
Fecha de Ingreso: agosto-2006
Ubicación: MiCasa-Valencia-España
Mensajes: 99
Antigüedad: 8 años, 1 mes
Puntos: 0
Respuesta: No se ven los acentos y ñ bien en rss

Yo utilizo este y me va de lujo xddd:
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  #6 (permalink)  
Antiguo 20/11/2008, 08:42
 
Fecha de Ingreso: noviembre-2008
Mensajes: 24
Antigüedad: 5 años, 10 meses
Puntos: 0
Respuesta: No se ven los acentos y ñ bien en rss

Esto ya lo había probado, y sigue sin funcionar. El caso es que en el resto de la web las 'ñ' y los acentos se ven perfectamente, pero en esta ventana que muestra noticias externas no... Creo que el problema puede estar a la hora de recoger las noticias con la sentencia readfile(). He buscado información al respecto de esta sentencia (estructura, parámetros...), pero no he encontrado nada...
Por eso le veo mala pinta al tema.
puedes ver el tema en www.luismolina.com

Gracias de nuevo...
César.
  #7 (permalink)  
Antiguo 20/11/2008, 08:47
Avatar de Carxl
Colaborador
 
Fecha de Ingreso: agosto-2006
Ubicación: Bogotá
Mensajes: 2.993
Antigüedad: 8 años, 1 mes
Puntos: 70
Respuesta: No se ven los acentos y ñ bien en rss

Bueno la verdad no sé si corresponda a php tu problema pero haz lo siguiente:

Con un editor de texto, bloc de notas(windwos), gedit(linux), coge el archivo php que presenta el problema, guárdalo con codificación "iso-8859-1" o "ANSI" en su defecto (el editor te da la opción). Normalmente cuando hago esto, se arreglan mis problemas de tildes y ñ.

Saludos
__________________
Hay 10 tipos de personas, los que entienden binario y los que no. (Anónimo)
www.programandoweb.com
  #8 (permalink)  
Antiguo 20/11/2008, 08:59
Avatar de rogertm
Mod->Cuba
 
Fecha de Ingreso: julio-2005
Ubicación: /home/Cuba/Habana/rogertm/
Mensajes: 2.900
Antigüedad: 9 años, 2 meses
Puntos: 628
Respuesta: No se ven los acentos y ñ bien en rss

es asi como dice Carxl... yo lo que hago, es que en las opciones de mi editor (Zend) le digo que todos los documentos sean UTF-8 y me evito todo ese gelengue

De todas formas si el problema persiste, bájate en el foro de XHTML que es ahí donde te darán la solucion.

saludos y suerte
__________________
Friki y Blogger por Cuenta Propia:213
Twenty'em: Theming is Prose
  #9 (permalink)  
Antiguo 20/11/2008, 09:07
 
Fecha de Ingreso: noviembre-2008
Mensajes: 24
Antigüedad: 5 años, 10 meses
Puntos: 0
Respuesta: No se ven los acentos y ñ bien en rss

He probado esto tambien y sigue yendo mal...
Bajare al foro de XHTML a ver si encuentro algo...

Gracias a todos!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:20.
SEO by vBSEO 3.3.2