Foros del Web » Programando para Internet » PHP »

Problema con la opción Enviar enlace...

Estas en el tema de Problema con la opción Enviar enlace... en el foro de PHP en Foros del Web. Pues estoy haciendo la opción de enviar el link a una página de la web, entonces necesito mandar en un mail la URL de la ...
  #1 (permalink)  
Antiguo 26/08/2003, 04:06
 
Fecha de Ingreso: febrero-2003
Mensajes: 47
Antigüedad: 14 años, 10 meses
Puntos: 0
Problema con la opción Enviar enlace...

Pues estoy haciendo la opción de enviar el link a una página de la web, entonces necesito mandar en un mail la URL de la página donde se encuentra el usuario. Lo he estado probando en mi servidor en local y me funciona perfectamente, creo la URL así:

$strUrl="http://".$_SERVER['SERVER_NAME'].$_SERVER['REQUEST_URI']

pero cuando lo he pasado a mi ISP me devuelve esto:

http://

Es decir no devuelven nada las variables $_SERVER.

¿Que pasa? Para obtener la url existe otra forma más facil,

MIL GRACIAS.
  #2 (permalink)  
Antiguo 26/08/2003, 15:57
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

Los arrays superglobales $_GET, $_POST, $_SERVER, ... existen solo desde la version 4.1 de PHP. Si tu hosting tiene una version anterior debes usar $HTTP_SERVER_VARS o si tienes register_globals a ON tambien puedes usar el nombre de la variable, como $SERVER_NAME. Mas info http://www.php.net/manual/en/reserved.variables.php

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:06.