Foros del Web » Programando para Internet » PHP »

soporte php para oracle en redhat 9.0

Estas en el tema de soporte php para oracle en redhat 9.0 en el foro de PHP en Foros del Web. Quisiera saber como dar soporte al php para que trabaje con oracle 8.1.7 con un servidor redhat 9. desde el cliente de oracle que esta ...
  #1 (permalink)  
Antiguo 07/12/2003, 14:30
 
Fecha de Ingreso: diciembre-2003
Mensajes: 1
Antigüedad: 14 años
Puntos: 0
soporte php para oracle en redhat 9.0

Quisiera saber como dar soporte al php para que trabaje con oracle 8.1.7 con un servidor redhat 9. desde el cliente de oracle que esta instalado en windows xp se puede ver perfectamente la base de datos pero con una pagina php no se puede. si alguien es tan amable de explicar como se hace se lo agradesco de ante mano.
  #2 (permalink)  
Antiguo 10/12/2003, 06:23
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
En un principio debes compilar PHP (de tu RedHad Linux) con opcion "Oracle" para instalar las extensiones de Oracle a PHP.

Despues vendría la conexión a tu Oracle en sí .. ahí no sé si te hará falta tambien instalar en tu servidor Linux (el que corre PHP) los clientes de Oracle para Linux .. pero es problable que también debas hacerlo.

màs info y configuración:
http://www.php.net/manual/en/ref.oci8.php

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #3 (permalink)  
Antiguo 10/12/2003, 07:59
Avatar de epplestun  
Fecha de Ingreso: octubre-2001
Mensajes: 1.621
Antigüedad: 16 años, 1 mes
Puntos: 5
Exacto, debes tener las librerias cliente de oracle y compilar tu php con soporte para oracle mediante: ./configure --with-oci8[=DIR]

En la página que te indico Cluster tienes toda la informacion detallada.

Ultimamente estoy leyendo por la lista de desarrollo de PHP (PHP-DEV) que la extension oci8 tiene problemillas ... dejo el dato para el que le interese, si quiere seguir la discusion que lo hagan desde www.zend.com

Saldudillos!!
__________________
Usuario registrado de Linux #288725
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:42.