Foros del Web » Programando para Internet » PHP » CodeIgniter »

la tabla no aparece ?

Estas en el tema de la tabla no aparece ? en el foro de CodeIgniter en Foros del Web. a ver si alguien ve el error porque yo llevo como 2 hs con esta garompa.. jejej simplemente la tabla no aparece, no hay html ...
  #1 (permalink)  
Antiguo 11/08/2012, 17:33
Avatar de patriciomase  
Fecha de Ingreso: abril-2012
Ubicación: Mar del Plata
Mensajes: 323
Antigüedad: 10 años, 3 meses
Puntos: 34
la tabla no aparece ?

a ver si alguien ve el error porque yo llevo como 2 hs con esta garompa.. jejej

simplemente la tabla no aparece, no hay html alguno generado, no hay error. nada. no se muestra

en la vista:
Código PHP:
Ver original
  1. $this->table->set_heading('','Coordenadas', 'Nombre', 'Luna', 'Tamaño');
  2. $tmp = array( 'table_open'  => '<table border=1>' );
  3. $this->table->set_template($tmp);
  4.  
  5. foreach($planets->result() as $planeta){
  6.     $array['coords'] = $planeta->coords;
  7.     $array['name'] = $planeta->name;
  8.     if($planeta->moon != 0){
  9.         $array['nombreLuna'] = $planeta->moon_name;
  10.         $array['tamanoLuna'] = $planeta->moon_size;
  11.     }
  12.     else{
  13.         $array['nombreLuna'] = " - - ";
  14.         $array['tamanoLuna'] = " - - ";    
  15. }
  16.  
  17.     $this->table->add_row($array);
  18.     print_r($array); //  muestra los datos correctamente cargados a $array
  19.     echo '<br/>';
  20. };
  21. $this->table->generate();

hasta el print_r veo bien los datos, o sea pasa algo en el add_row(), o el generate() ??? igualmente generé la tabla sin el helper y listo, me cansé. pero si alguien ve el error me gustaría saberlo
  #2 (permalink)  
Antiguo 12/08/2012, 13:27
Avatar de Ronruby  
Fecha de Ingreso: julio-2008
Ubicación: 18°30'N, 69°59'W
Mensajes: 4.879
Antigüedad: 14 años, 1 mes
Puntos: 416
Respuesta: la tabla no aparece ?

Le estas pasando un array asociativo a add_row(), pasale un array donde los indices sean numericos.
Otra cosa, el $this->table->generate(); genera la tabla, pero solo devuelve el HTML, no lo imprime. Es:
echo $this->table->generate();
  #3 (permalink)  
Antiguo 12/08/2012, 13:34
Avatar de patriciomase  
Fecha de Ingreso: abril-2012
Ubicación: Mar del Plata
Mensajes: 323
Antigüedad: 10 años, 3 meses
Puntos: 34
Respuesta: la tabla no aparece ?

jajaj no te lo puedo creer le faltaba el echo!! pasé creo 2 hs buscando, cambiando cosas, pasando indices numéricos, imprimiendo variables .... a veces uno se bloquea y no ve estos errores tan tontos

gracias

Etiquetas: helper, table
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 03:45.