Foros del Web » Creando para Internet » CSS »

Condicional de CSS no funciona con IIS

Estas en el tema de Condicional de CSS no funciona con IIS en el foro de CSS en Foros del Web. Hola a todos/as Os quería preguntar sobre un problema que me ha surgido. Tengo una web que estaba desarrollando en puro X H T M ...
  #1 (permalink)  
Antiguo 25/05/2009, 12:24
 
Fecha de Ingreso: abril-2008
Mensajes: 11
Antigüedad: 9 años, 8 meses
Puntos: 0
Pregunta Condicional de CSS no funciona con IIS

Hola a todos/as

Os quería preguntar sobre un problema que me ha surgido.

Tengo una web que estaba desarrollando en puro X H T M L+CSS. Después me pase al P.H.P simplemente para utilizar la función "include" de P.H.P. Así que instalé P.H.P y el IIS. Hasta aqui todo bien, los "include" funcionan.

Al comienzo de cada página tengo un selector del tipo [if IE] para que me cargue una hoja de estilos adicional si cargamos la página con cualquier IE.
Mi sorpresa cuando vi que al cargar la misma página en IIS con IE6 no hace caso al selector y no coge la CSS para IE. En cambio si cargo la página original en el IE6 (sin cargarla a través de IIS) sí que funciona el selector condicional y lee la hoja de estilos correspondiente.

¿A alguien le ha pasado alguna vez esto?
Cualquier idea será bienvenida.

Muchas gracias a todos/as.
  #2 (permalink)  
Antiguo 25/05/2009, 15:11
 
Fecha de Ingreso: enero-2008
Ubicación: #Callao {Lima:Perú;}
Mensajes: 144
Antigüedad: 9 años, 11 meses
Puntos: 7
Respuesta: Condicional de CSS no funciona con IIS

Verifica bien si están cerrado los divs, es posible que te falta alguna etiqueta cerrarla o este mal ubicada cuando lo hallas implementado al php

Salu2
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:43.