Foros del Web » Creando para Internet » CSS »

Problemas con los div

Estas en el tema de Problemas con los div en el foro de CSS en Foros del Web. Hola a todos. Esta es la primera vez que escribo asin que perdonadme si voy de nuevas. Tengo el siguiente codigo: <!DOCTYPE HTML PUBLIC "-//W3C//DTD ...
  #1 (permalink)  
Antiguo 09/11/2005, 16:55
 
Fecha de Ingreso: noviembre-2005
Mensajes: 2
Antigüedad: 12 años, 1 mes
Puntos: 0
Problemas con los div

Hola a todos.
Esta es la primera vez que escribo asin que perdonadme si voy de nuevas.
Tengo el siguiente codigo:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
<head>
<style type="text/css">
html, body {
margin: 0px;
padding: 0px;
border: 0px;
width: 100%;
height: 100%;
}
.tabla {
margin: 0px;
padding: 0px;
width: 100%;
border: 1px solid red;
}
.tabla th {
text-align: left;
}
.tabla td {
}
.nota {
margin: 0px;
padding: 0px;
border: 1px solid red;
background: #FFFFCC;
width: 100%;
}
</style>
</head>

<body>
<table class="tabla" cellpadding="0" cellspacing="0">
<tr><th>C1</th><th>C2</th><th>C3</th><th>C4</th></tr>
<tr><td>1</td><td>2</td><td>3</td><td>4</td></tr>
<tr><td>5</td><td>6</td><td>7</td><td>8</td></tr>
<tr><td>9</td><td>10</td><td>11</td><td>12</td></tr>
</table>

<div class="nota">
Este es el contenido 2.
</div>

<form method="get" action="iframe_content.html">
<input type="submit" value="siguiente">
</form>
</body>
</html>


En IE 6 se ve bien, la tabla y el div tienen el mismo tamaño, pero en firefox 1.0.7 nada de nada, el div mide 2 pixels mas que la tabla y aparece un scroll.

Que se podria hacer???

Gracias.
  #2 (permalink)  
Antiguo 09/11/2005, 17:51
Avatar de leoj90
Usuario baneado!
 
Fecha de Ingreso: agosto-2005
Mensajes: 1.365
Antigüedad: 12 años, 4 meses
Puntos: 0
Lo deberia mostrar.. pero bueno, eso pasa con esos navegadores raros.
  #3 (permalink)  
Antiguo 09/11/2005, 18:02
 
Fecha de Ingreso: noviembre-2005
Mensajes: 2
Antigüedad: 12 años, 1 mes
Puntos: 0
encontre una solucion algo extraña...

Encontre una solucion algo extraña y que funciona:

si quito el width: 100% del div (la clase definida como nota), funciona correctamente en internet explorer y en firefox.

¿Alguien sabe por que????

Gracias.
  #4 (permalink)  
Antiguo 09/11/2005, 18:26
Avatar de webosiris
Moderador egiptólogo
 
Fecha de Ingreso: febrero-2002
Ubicación: Luxor, Egipto
Mensajes: 10.727
Antigüedad: 15 años, 9 meses
Puntos: 997
Cita:
pero bueno, eso pasa con esos navegadores raros.
Eso pasa con los navegadores que interpretan correctamente los estándares de la W3C

Lo correcto es como te lo muestra el Firefox... IE interpreta mal el modelo de cajas. Te dejo la explicación: http://www.disenorama.com/articulos/...o_de_cajas.htm
__________________
Pasamos tus PSD a HTML

Pobre del que lo sabe todo, porque no tiene nada más que aprender ni razón para vivir. -
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:46.