Foros del Web » Programación para mayores de 30 ;) » Bases de Datos General » Mysql »

[SOLUCIONADO] Problemas con codificación de carateres

Estas en el tema de Problemas con codificación de carateres en el foro de Mysql en Foros del Web. Buenas gente, Tengo una DB (MySQL) con las siguientes características: Cotejamientos de los todos los campos de todas las tablas: utf8_general_ci Cotejamiento de la base ...
  #1 (permalink)  
Antiguo 02/08/2014, 17:11
Avatar de guille_delfino  
Fecha de Ingreso: julio-2014
Ubicación: Buenos Aires, Argentina
Mensajes: 125
Antigüedad: 8 años
Puntos: 4
Pregunta Problemas con codificación de carateres

Buenas gente,

Tengo una DB (MySQL) con las siguientes características:

Cotejamientos de los todos los campos de todas las tablas: utf8_general_ci
Cotejamiento de la base de datos y las tablas: ut8_general_ci
Motor: InnoDB

Cuando llamo a la tabla desde el sitio, todo lo que tenga tildes, o símbolos como "°", no muestra nada, no muestra el campo completo, nada de nada.

El sitio lo configuré con <meta charset="UTF-8">

Probé con Latin1_spanish_ci, con utf8_bin y con utf8_spanish_ci en la DB y nada.

Cambié <meta charset="ISO-8859-1"> y tampoco me muestra los datos pero los caracteres del sitio se cambian a símbolos por lo cual volví a utf8..

Como dato adicional comento que los datos a la DB fueron importados desde un Excel con load data infile utilizando CHARACTER SET latin1

Gracias desde ya!
__________________
Atentamente,

Guillermo Delfino
[email protected]
  #2 (permalink)  
Antiguo 02/08/2014, 17:47
Avatar de gnzsoloyo
Moderador criollo
 
Fecha de Ingreso: noviembre-2007
Ubicación: Actualmente en Buenos Aires (el enemigo ancestral)
Mensajes: 23.324
Antigüedad: 14 años, 7 meses
Puntos: 2658
Respuesta: Problemas con codificación de carateres

Cita:
<meta charset="UTF-8">
Cita:
<meta charset="ISO-8859-1">
Estos son temas ajenos a la base. Están relacionados con la pagina web, y por definición son independientes del servidor de base de datos.
La definición de los campos que mencionas están bien, pero el problema es que si las paginas las tienes bien y la base igual, pero la conexión no, a la base está llegando basura, y por consecuencia se está almacenando basura.

Vamos al principio:
Cita:
Como dato adicional comento que los datos a la DB fueron importados desde un Excel con load data infile utilizando CHARACTER SET latin1
Si tienes las tablas en UTF8, y metes datos en Latin1, es más que evidente que tendrás problemas. Como mínimo deberías compensar eso realizando una conversión de formato del archivo recibido, o procesarlo para generar uno nuevo en el formato adecuado.
__________________
¿A quién le enseñan sus aciertos?, si yo aprendo de mis errores constantemente...
"El problema es la interfase silla-teclado." (Gillermo Luque)
  #3 (permalink)  
Antiguo 03/08/2014, 20:37
Avatar de guille_delfino  
Fecha de Ingreso: julio-2014
Ubicación: Buenos Aires, Argentina
Mensajes: 125
Antigüedad: 8 años
Puntos: 4
Respuesta: Problemas con codificación de carateres

Gracias por tu respuesta, pude resolver el inconveniente, deje todo en utf8 excepto la conexión a la base de datos que la configure el latin1 y funciono correctamente.

Gracias !?
__________________
Atentamente,

Guillermo Delfino
[email protected]
  #4 (permalink)  
Antiguo 04/08/2014, 05:02
Colaborador
 
Fecha de Ingreso: marzo-2008
Ubicación: Cáceres
Mensajes: 3.735
Antigüedad: 14 años, 3 meses
Puntos: 300
Respuesta: Problemas con codificación de carateres

guille_delfino,
eso no tiene mucho sentido y tarde o temprano creo que tendrás problemas.
La conexión ha de hacerse con la codificación utf8 y no latin 1. Tu problema, pienso, sigue siendo la exportación de la información desde excel con codificación latin1. Tienes que exportarla como utf8 e importarla a la base como utf8. Y la conexión ha de hacerse también como utf8.
  #5 (permalink)  
Antiguo 05/08/2014, 19:58
Avatar de guille_delfino  
Fecha de Ingreso: julio-2014
Ubicación: Buenos Aires, Argentina
Mensajes: 125
Antigüedad: 8 años
Puntos: 4
Respuesta: Problemas con codificación de carateres

Si, entiendo lo que me explicas y estoy de acuerdo. Intente exportarlo como utf8 e importarlo como utf8, el problema es que al hacerlo, los datos de los campos se cortan, por ejemplo, si tomo el excel y lo codifico a utf8 y luego hago el load data infile con utf8 los datos se cortan donde hay tildes o símbolos, por ejemplo, si en el campo nombre hay un valor Agustín, me lo pone como Agust, o si es Calle 2º y 3º me pone Calle, lo corta y eso mismo pasa con todos los datos, los podría corregir pero son en total ente todas las tablas unos 7.000 registros.

Eso es lo que me pasa al hacerlo en utf8, ahora así como lo configure, en el sitio se ve bien, en el sistema Auto administrable se ve bien pero entrando a la db directamente desde PHPMyAdmin se ve con símbolos, |Á en lugar de acentos y demás.

Voy a seguir intentando encontrarle una solución.
__________________
Atentamente,

Guillermo Delfino
[email protected]
  #6 (permalink)  
Antiguo 06/08/2014, 03:32
Colaborador
 
Fecha de Ingreso: marzo-2008
Ubicación: Cáceres
Mensajes: 3.735
Antigüedad: 14 años, 3 meses
Puntos: 300
Respuesta: Problemas con codificación de carateres

Si estás usando un archivo de paso desde el excel a MySQL, por ej. un archivo de texto con terminación txt o csv o cualquier otra de este tipo, te recomiendo que vigiles la codificación en ese archivo y luego importes desde MySQL ese archivo. Es habitual guardar eso en un bloc de notas o en un editor. Antes de importar ese archivo guarda los datos de ese archivo con codificación utf8 (en el bloc de notas la codificación la estableces en guardar como), y luego importas.
  #7 (permalink)  
Antiguo 07/08/2014, 17:59
Avatar de guille_delfino  
Fecha de Ingreso: julio-2014
Ubicación: Buenos Aires, Argentina
Mensajes: 125
Antigüedad: 8 años
Puntos: 4
Respuesta: Problemas con codificación de carateres

Voy a probarlo y luego te digo como me fue.
__________________
Atentamente,

Guillermo Delfino
[email protected]
  #8 (permalink)  
Antiguo 14/08/2014, 17:49
Avatar de guille_delfino  
Fecha de Ingreso: julio-2014
Ubicación: Buenos Aires, Argentina
Mensajes: 125
Antigüedad: 8 años
Puntos: 4
Respuesta: Problemas con codificación de carateres

Resuelto, me faltaba configurar la codificación de la conexión ala DB en el sitio que por defecto esta en latin1.

Gracias !
__________________
Atentamente,

Guillermo Delfino
[email protected]

Etiquetas: charset, codificacion, iso-8859-1, utf-8
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 06:14.