Foros del Web » Creando para Internet » Diseño web »

Problema LightBox + htaccess

Estas en el tema de Problema LightBox + htaccess en el foro de Diseño web en Foros del Web. Hola a todos. Estoy intentando implementar un lightbox en una galeria de fotos. El problema que tengo es que no se que pasa, pero a ...
  #1 (permalink)  
Antiguo 25/11/2009, 13:44
 
Fecha de Ingreso: diciembre-2007
Mensajes: 77
Antigüedad: 10 años
Puntos: 3
Problema LightBox + htaccess

Hola a todos.
Estoy intentando implementar un lightbox en una galeria de fotos. El problema que tengo es que no se que pasa, pero a causa de la configuracion de mi htacces, los lightbox que he probado no funcionan.

Los que he probado son el Shadowbox y el Sexy-Lightbox, y ninguno tira bien. Al borrar las reglas de htaccess se soluciona, pero claro, no es tema de quitarlas.

Haber si alguien sabe cual es el problema y como solucionarlo, o si me puede decir algun Lightbox que no tenga problemas con el htaccess.

Gracias a todos.
  #2 (permalink)  
Antiguo 26/11/2009, 05:22
 
Fecha de Ingreso: diciembre-2007
Mensajes: 77
Antigüedad: 10 años
Puntos: 3
Respuesta: Problema LightBox + htaccess

Nadie a tenido nunca ese problema???
  #3 (permalink)  
Antiguo 26/11/2009, 06:10
Avatar de maycolalvarez
Colaborador
 
Fecha de Ingreso: julio-2008
Ubicación: Caracas
Mensajes: 12.120
Antigüedad: 9 años, 4 meses
Puntos: 1530
Respuesta: Problema LightBox + htaccess

nada tiene que ver javascript con el server, ¿el módulo mod-rewrite de apache está activado? de lo contrario algunas htaccess no fuincionarán.

el lightbox se ejecuta en el cliente (javascript), si bien es cierto que puede invocar la descarga de imágenes, éstas deben de tener permisos de lectura (lo que normalmente tienen) para verlas, si la regla de anti-hotlink está mal escrita es obvio que no puedan mostrarse también.
  #4 (permalink)  
Antiguo 26/11/2009, 06:24
 
Fecha de Ingreso: diciembre-2007
Mensajes: 77
Antigüedad: 10 años
Puntos: 3
Respuesta: Problema LightBox + htaccess

Bufff, un momento de lucidez me ha resuelto el problema.

Este estaba en las reglas de el htaccess.

Solo he tenido que filtrarlas para que no actuen en las carpetas de los scripts, css y demas, aunque lo que no entiendo es creia que no era necesario.

Bueno, aki el codigo que lo ha solucionado...
Código htaccess:
Ver original
  1. RewriteEngine On
  2. RewriteRule ^galerias/(.*)$   galerias/$1 [L]
  3. RewriteRule ^lib/(.*)$   lib/$1 [L]
  4. RewriteRule ^css/(.*)$   css/$1 [L]
  5. RewriteRule ^flash/(.*)$   flash/$1 [L]
  6. RewriteRule ^(.*)/(.*)/(.*)/(.*)$   /seccion/$1/$2.php?id=$3&pag=$4
Siendo lib la carpeta con todos los scripts
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:24.