Foros del Web » Creando para Internet » Diseño web »

Problemas al escribir símbolos, interrogaciones y exclamaciones en mi web.

Estas en el tema de Problemas al escribir símbolos, interrogaciones y exclamaciones en mi web. en el foro de Diseño web en Foros del Web. Hola amigos/as: He adquirido un portal de anuncios clasificados de muy reciente creación, y bueno, cabe decir que hacen falta más conocimientos de los que ...
  #1 (permalink)  
Antiguo 16/12/2008, 13:46
ANUMAN_70
Invitado
 
Mensajes: n/a
Puntos:
Problemas al escribir símbolos, interrogaciones y exclamaciones en mi web.

Hola amigos/as:

He adquirido un portal de anuncios clasificados de muy reciente creación, y bueno, cabe decir que hacen falta más conocimientos de los que yo poseo para poder llevarlo y sacarlo adelante. Estoy recabando información en muchas páginas web para instruirme y solucionar algunos problemas. Uno de los que me urge ahora, es la escritura. Después de publicado un artículo y en casi todas las ocasiones, en vez de aparecer una interrogación, exclamación u otro símbolo que necesitara para el mismo, lo que se ve es la instrucción HTML que forma el símbolo y eso queda muy antiestético de cara a los/as usuarios/as y visitantes de la web.
¿Sabéis alguno como puedo solucionar eso? He intentado varias cosas. Por poner un ejemplo, si se trata de un espacio en blanco, lo que hago es intentar borrarle y sino puedo, le resalto con fondo blanco o poniendo un punto en lugar del espacio en blanco para de seguido resaltarlo con color blanco y de esa forma no se ve. Este método, no es que sea muy original, pero por ahora me tengo que conformar hasta que resuelva el problema. No quiero tardar mucho tiempo, porque me expongo a que los robots de los buscadores, al indexar la página les de por desestimarla.

Saludos cordiales y muchas gracias de antemano
  #2 (permalink)  
Antiguo 16/12/2008, 16:26
Avatar de Triby
Mod on free time
 
Fecha de Ingreso: agosto-2008
Ubicación: $MX->Gto['León'];
Mensajes: 9.741
Antigüedad: 9 años, 4 meses
Puntos: 2113
Respuesta: Problemas al escribir símbolos, interrogaciones y exclamaciones en mi web.

Que codificacion estas usando: ISO o UTF?
Como ingresas esos caracteres especiales en tu sitio?
Lo que aparece en vez de á es á?
__________________
- León, Guanajuato
- GV-Foto
  #3 (permalink)  
Antiguo 16/12/2008, 17:17
 
Fecha de Ingreso: noviembre-2006
Ubicación: Evergreen Street
Mensajes: 239
Antigüedad: 11 años, 1 mes
Puntos: 2
Respuesta: Problemas al escribir símbolos, interrogaciones y exclamaciones en mi web.

Como he solucionado el problemas de los símbolos, tildes y eñes es colocando en la codificación de las páginas el siguiente METTA:
Código:
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">
y luego en mis Bases de Datos de MySQL utilizo el cotejamiento
Código:
utf8_spanish_ci
y ya no he tenido problemas.

Última edición por otto1303; 16/12/2008 a las 21:01
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:30.