Ver Mensaje Individual
  #1 (permalink)  
Antiguo 02/10/2012, 19:18
minombreesmm
 
Fecha de Ingreso: agosto-2012
Ubicación: M.
Mensajes: 2.031
Antigüedad: 11 años, 10 meses
Puntos: 52
funcion copy php, que estoy haciendo mal?

Código PHP:
Ver original
  1. copy("C:\xampp\htdocs\p5\RegistroUsuarios\nofoto\Nofoto.jpg","C:\xampp\htdocs\p5\RegistroUsuarios\imagenes\avatares\nuevo.jpg");


ese no me funciona pero si me funciona con el input file


donde hago esto:

Código PHP:
Ver original
  1. $avatar= "imagenes/avatares/".$idimagen."/".$_FILES['archivo']['name'];
  2.  
  3.     copy($_FILES['archivo']['tmp_name'],str_replace(" ","_",$avatar));

y si funciona.


las carpetas ya estan creadas..


me baso en este ejemplo


Código PHP:
Ver original
  1. copy(file,to_file)

Parameter Description
file Required. Specifies the file to copy
to_file Required. Specifies the file to copy to

Tips and Notes

Note: If the destination file already exists, it will be overwritten.

Example

Código PHP:
Ver original
  1. <?php
  2. echo copy("source.txt","target.txt");
  3. ?>

solo que en el ejemplo de arriba ocupo meter directamente una imagen en un directorio ya creado previamente para que el usuario que dijo "No incluir foto" tenga una por default.. si ya se, me diran que guarde solo la ruta de la imagen por default... el detalle es que necesariamente esa imagen por default quiero que aparezca en su galeria de fotos, no solo en la de perfil...pero no funciona, no la guarda...

y si tengo permisos de escritura pues con el input file si funciona

de antemano gracias

Última edición por minombreesmm; 02/10/2012 a las 19:25