Ver Mensaje Individual
  #5 (permalink)  
Antiguo 06/03/2013, 08:01
Avatar de chuidiang
chuidiang
Colaborador
 
Fecha de Ingreso: octubre-2004
Mensajes: 3.774
Antigüedad: 19 años, 9 meses
Puntos: 454
Respuesta: problemas con ejb y ajax

Hola:

JEE6 no tiene "nada que ver" con el jdk, son instalaciones distintas. La base es el JRE (el runtime), luego viene el JDk (el compilador, que debe ser versión 1.5 o superior para que no te de error) y finalmente viene el JEE, que no deja de ser una "librería" adicional al JRE o JDK.

Lo primero, asegúrate que el jdk que tienes es moderno (Suele estar en C:\Archivos de Programa\java y el subdirectorio ahí dentro suele indicarte la versión (yo por ejemplo, ahí debajo tengo jdk1.6.0_20 y jre6). Si tienes varios, mira a ver cual está en el path.

El siguiente tema es el IDE (eclipse, netbeans, etc) o herramienta que estés usando para compilar. Aunque el compilador javac sea moderno, tiene opciones para hacer compatibles los fuentes con versiones anteriores. Asegúrate que en ningún sitio viene algo como -source=1.4. Por ejemplo, si usas maven, por defecto usa -source=1.3, con lo que tienes ese tipo de problemas.

Otra más con el IDE, si tienes varios jdk instalados (a veces incluso el IDE, especialmente netbeans tiene esa manía, te instala uno propio y no en el directorio habitual), el IDE se puede configurar para usar uno u otro jdk. Revisa que tu IDE esté configurado para usar el jdk moderno.

Se bueno.
__________________
Apuntes Java
Wiki de Programación