Ver Mensaje Individual
  #18 (permalink)  
Antiguo 23/07/2014, 15:19
jeremiselxi
(Desactivado)
 
Fecha de Ingreso: septiembre-2008
Mensajes: 269
Antigüedad: 15 años, 2 meses
Puntos: 22
Respuesta: VIEWS > Link que muestre los post con 'x' termino, que ha creado un usuari

Cita:
Iniciado por raulfw Ver Mensaje
En primer lugar, darte infinitas gracias por el manual que has redactado para ayudarme. Es todo un detalle JEREMI!!!

Despues de pasarme todo el dia con el tema. He de reconocer que no he conseguido hacerlo al 100%. Y me he quedado justo en el ultimo paso. Me explico.

He reproducido exactamente todos los pasos indicados, incluso llamando a las vistas con los mismos nombres. El resultado a sido el siguiente:

- Las 2 vistas se generan correctamente.
- La segunda, (la mas importante) cuando le cambio el argumento dentro de VIEWS obedece. Y en en el navegador cambiandole el ID de termino al final (por ejemplo: http://dominio.com/vista_con_usuario_3/26 tambien hace su trabajo, y filtra correctamente.

Sin embargo el bloque no me funciona. (El filtro PHP esta activado, que quede claro)

He pensado sobre las diferentes causas que podrian estar fallando.

Hay que tener en cuenta que mi instalacion NO ES DESDE 0, es decir, que la web esta activa y a sido muy modificada.

Hay un momento en el que dices:
- y damos click donde dice Tax1
- Y observamos que el link es el siguiente: http://localhost/drupal6/taxonomy/term/1 lo que nos intereza es cambiar el código siguiente en la parte donde dice node

Sin embargo a mi me pasa que mi ruta es diferente por que esta modificada con 'URL Aliases > Automated alias settings > Default path pattern (applies to all vocabularies with blank patterns below): category/[vocab-raw]/[catpath-raw]

y me queda asi:

http://dominio.com/category/famosas/spain/sandra-golpe

Ademas, Sandra Golpe es hijo de 'Spain'. Vaya un lio...

No se si puede ser esto lo que hace que falle. Es lo unico que se me ocurre.

Otra pista, es que donde deberia afectar el bloque (en la pagina que tu me indicas), aparece un espacio en blanco. Al mirar con Firebug sobre ese lugar, veo que el bloque esta alli, y puedo ver incluso el codigo en PHP, algo extraño, no?

¿Que opinas?

MUCHAS GRACIAS POR LA AYUDA JEREMI!!
Con relacion al bloque no saldrá nada ya que el bloque de codigo esta en jquery y como tal no se muestra.

Com relacion a donde dices
[QUOTE][

Sin embargo a mi me pasa que mi ruta es diferente por que esta modificada con 'URL Aliases > Automated alias settings > Default path pattern (applies to all vocabularies with blank patterns below): category/[vocab-raw]/[catpath-raw]

y me queda asi:

http://dominio.com/category/famosas/spain/sandra-golpe

/QUOTE]

El tema esta en que el tutorial esta basado en que la primera vista le pasa el id del término y se la envia a la otra vista. Has esto, uosa la primera vista que te hice y dale click a varios terminos diferentes y copia las url para verificar si en cierta forma esta pasando los id de los terminos.

Por otra parte como tu tienes configado las taxonomias??

Tienes varios vocabularios??? Pon aqui si tienes varios vocabularios y sus términos para verificar como adapto el scrip para ti. Saludos