Foros del Web » Programando para Internet » Python »

problema django 1.5 debug false da error 500 y no muestra css

Estas en el tema de problema django 1.5 debug false da error 500 y no muestra css en el foro de Python en Foros del Web. hola tengo un problema django 1.5 con debug false me da un error 500 y no muestra css ni nada del media agregue Código: ALLOWED_HOSTS ...
  #1 (permalink)  
Antiguo 17/07/2013, 21:15
 
Fecha de Ingreso: diciembre-2011
Mensajes: 408
Antigüedad: 12 años, 6 meses
Puntos: 18
problema django 1.5 debug false da error 500 y no muestra css

hola tengo un problema django 1.5 con debug false me da un error 500 y no muestra css ni nada del media agregue

Código:
ALLOWED_HOSTS = ['localhost','196.168.1.100','192.168.1.101']
pero sigue sin mostrarme los archivos estoy preparando mi website para produccion
  #2 (permalink)  
Antiguo 17/07/2013, 21:44
Avatar de razpeitia
Moderador
 
Fecha de Ingreso: marzo-2005
Ubicación: Monterrey, México
Mensajes: 7.321
Antigüedad: 19 años, 3 meses
Puntos: 1360
Respuesta: problema django 1.5 debug false da error 500 y no muestra css

Usa el nombre de tu host.

Código Python:
Ver original
  1. ALLOWED_HOSTS = ['example.com', 'www.example.com']

No olvides hacer un reload del server una vez que cambies la configuración.
  #3 (permalink)  
Antiguo 18/07/2013, 11:38
Avatar de Carlangueitor
Moderador ლ(ಠ益ಠლ)
 
Fecha de Ingreso: marzo-2008
Ubicación: México
Mensajes: 10.037
Antigüedad: 16 años, 3 meses
Puntos: 1329
Respuesta: problema django 1.5 debug false da error 500 y no muestra css

No creo que sea error de esa configuración con los estáticos, a menos que te den error 500 esos archivos. Quizá es una mala configuración de tu servidor, ¿estás usando apache o algo así?
__________________
Grupo Telegram Docker en Español
  #4 (permalink)  
Antiguo 18/07/2013, 13:49
 
Fecha de Ingreso: diciembre-2011
Mensajes: 408
Antigüedad: 12 años, 6 meses
Puntos: 18
Respuesta: problema django 1.5 debug false da error 500 y no muestra css

no estoy usando el comando python manage.py runserver 0.0.0.0:8000
  #5 (permalink)  
Antiguo 18/07/2013, 13:53
Avatar de razpeitia
Moderador
 
Fecha de Ingreso: marzo-2005
Ubicación: Monterrey, México
Mensajes: 7.321
Antigüedad: 19 años, 3 meses
Puntos: 1360
Respuesta: problema django 1.5 debug false da error 500 y no muestra css

Haz lo siguiente:

Pon ALLOWED_HOSTS = ['*'] si funciona con debug = False entonces tienes mal configurado ALLOWED_HOSTS. Configuralo bien.

Si no esto no te funciona entonces es otra cosa que tienes mal.

Otra cosa no sirvas el contenido estático a través de django hazlo por medio del servidor web. Configura y lee los los logs así puedes saber rápidamente donde esta el error.

PD: A menos que sea para pruebas nunca por ningún motivo debes de dejar ALLOWED_HOSTS = ['*'] en producción.
  #6 (permalink)  
Antiguo 18/07/2013, 13:53
Avatar de Carlangueitor
Moderador ლ(ಠ益ಠლ)
 
Fecha de Ingreso: marzo-2008
Ubicación: México
Mensajes: 10.037
Antigüedad: 16 años, 3 meses
Puntos: 1329
Respuesta: problema django 1.5 debug false da error 500 y no muestra css

A ver, parece que no entendí.

¿Te sale un error 500? ¿O los assets no se muestran?
__________________
Grupo Telegram Docker en Español
  #7 (permalink)  
Antiguo 18/07/2013, 14:16
 
Fecha de Ingreso: diciembre-2011
Mensajes: 408
Antigüedad: 12 años, 6 meses
Puntos: 18
Respuesta: problema django 1.5 debug false da error 500 y no muestra css

Cita:
Iniciado por Carlangueitor Ver Mensaje
A ver, parece que no entendí.

¿Te sale un error 500? ¿O los assets no se muestran?
en algunas paginas me da error y los assets no se muestran

Etiquetas: 500, css, debug, django, false, muestra
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:04.