Foros del Web » Creando para Internet » Sistemas de gestión de contenidos » Drupal »

Consulta. Problema con Archiver para Blog

Estas en el tema de Consulta. Problema con Archiver para Blog en el foro de Drupal en Foros del Web. Buenas!!.. Les hago una consulta. Estoy haciendo un blog a modo de prueba. Estuve siguiendo un tuto, el cual explica como crear un archiver para ...
  #1 (permalink)  
Antiguo 11/09/2014, 13:07
af1
 
Fecha de Ingreso: junio-2010
Mensajes: 87
Antigüedad: 13 años, 9 meses
Puntos: 2
Consulta. Problema con Archiver para Blog

Buenas!!.. Les hago una consulta. Estoy haciendo un blog a modo de prueba. Estuve siguiendo un tuto, el cual explica como crear un archiver para filtrar los post linkeados como "mes/año".

Básicamente lo que hice fué:
1-Con Devel crear contenido de prueba.
2-Crear view para agrupar por mes/año
3-Crear un block para el archiver (Contextual Filters. Content: Created year + month)
4-Posicioné el bloque en la en Sidebar second.

El problema es que cuando hago click en algún enlace del archiver, me tira un "Page not found. The requested page "/prueba1/blog/201405" could not be found. "

Mi duda es si hace falta alguna configuración extra sobre la gestión de URL. Ó falta alguna configuración sobre la View del archiver.

Gracias, saludos!!
  #2 (permalink)  
Antiguo 12/09/2014, 01:36
Avatar de MarioAraque
Colaborador
 
Fecha de Ingreso: octubre-2009
Ubicación: Valencia
Mensajes: 1.398
Antigüedad: 14 años, 6 meses
Puntos: 265
Respuesta: Consulta. Problema con Archiver para Blog

Hola @af1

Cuando decís "Crear view para agrupar por mes/año", te referís a que activaste la vista "Archive" que viene por defecto con views?

La url que ponés de ejemplo no parece que mencione esa vista por defecto, que creo que te va a solucionar todos tus problemas. Te recomiendo que la utilices porque hasta te proveé de un bloque que podés añadir al sidebar second sin problemas.

Saludos.
  #3 (permalink)  
Antiguo 12/09/2014, 05:32
af1
 
Fecha de Ingreso: junio-2010
Mensajes: 87
Antigüedad: 13 años, 9 meses
Puntos: 2
Respuesta: Consulta. Problema con Archiver para Blog

Hola Mariano, gracias por la respuesta.

La configuración que seguí del tuto, es la siguiente:

Para crear view para agrupar por mes/año:



Y para crear un block para el archiver (Contextual Filters. Content: Created year + month):




Esa sería la configuración por defecto?

Gracias, saludos!
  #4 (permalink)  
Antiguo 12/09/2014, 06:59
Avatar de MarioAraque
Colaborador
 
Fecha de Ingreso: octubre-2009
Ubicación: Valencia
Mensajes: 1.398
Antigüedad: 14 años, 6 meses
Puntos: 265
Respuesta: Consulta. Problema con Archiver para Blog

Soy Mario, jeje.

Lo que debés hacer es ir a admin/structure/views y ver el listado de vistas que tenés, y habilitar la vista "Archive". No te hace falta crear una nueva. Esa vista ya te filtra por mes y tiene hasta bloques que podés añadir a las regiones de tu theme.

Saludos.
  #5 (permalink)  
Antiguo 15/09/2014, 05:53
af1
 
Fecha de Ingreso: junio-2010
Mensajes: 87
Antigüedad: 13 años, 9 meses
Puntos: 2
Respuesta: Consulta. Problema con Archiver para Blog

Mario, muchas gracias!.. quedó funcionando y todo... un abrazo!

Etiquetas: blog
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:24.