Foros del Web » Creando para Internet » Sistemas de gestión de contenidos » Drupal »

[SOLUCIONADO] Problema al agregar nuevo contenido-nodo (El form se recarga y no guarda)

Estas en el tema de Problema al agregar nuevo contenido-nodo (El form se recarga y no guarda) en el foro de Drupal en Foros del Web. Tengo un problema al crear contenidos (aka: node). No se si el problema es del Drupal o alguna configuración del server. Entro a crear un ...
  #1 (permalink)  
Antiguo 12/05/2014, 16:56
Avatar de anacona16  
Fecha de Ingreso: marzo-2010
Ubicación: Bogota DC
Mensajes: 610
Antigüedad: 14 años, 1 mes
Puntos: 52
Problema al agregar nuevo contenido-nodo (El form se recarga y no guarda)

Tengo un problema al crear contenidos (aka: node).

No se si el problema es del Drupal o alguna configuración del server.

Entro a crear un nodo.
Digito todos los campos.
Al presionar el boton guardar la pagina se refresca en el mismo formulario y no guarda nada.

Hasta después de intentar tres veces el nodo se guarda.

Estaba usando Drupal 7.28 pero decidi dejar Drupal 7.26, la razón es que tengo otro sitio en otro server con Drupal 7.26 y no pasa ese error, por eso decidi hacer un downgrade al Drupal, para verificar si esa era la falla.

Después de dejar Drupal 7.26 el error persiste, no se si deba ha algún tiempo de espera establecido en la configuración del server.

Espero puedan ayudarme.

Gracias.
__________________
Aprendiendo!!!
  #2 (permalink)  
Antiguo 12/05/2014, 23:22
Avatar de MarioAraque
Colaborador
 
Fecha de Ingreso: octubre-2009
Ubicación: Valencia
Mensajes: 1.398
Antigüedad: 14 años, 5 meses
Puntos: 265
Respuesta: Problema al agregar nuevo contenido-nodo (El form se recarga y no guarda)

En el admin de Drupal debés ir a los mensajes recientes del registro y ver si hay algún fallo, que estoy seguro que debe haber.

Ya con eso podremos saber exactamente qué es lo que te pasa, porque pocas conclusiones podemos sacar con la información que nos das.

Saludos.
  #3 (permalink)  
Antiguo 12/05/2014, 23:39
Avatar de anacona16  
Fecha de Ingreso: marzo-2010
Ubicación: Bogota DC
Mensajes: 610
Antigüedad: 14 años, 1 mes
Puntos: 52
Respuesta: Problema al agregar nuevo contenido-nodo (El form se recarga y no guarda)

Gracias MarioAraque por tu respuesta, reviso el log y ya les contare.

Es raro porque despues de dar click en guardar y que el form queda vacio si le doy recargar al navegador me pide confirmacion de reenviar el formulario, si doy aceptar entonces el nodo si se guarda.
__________________
Aprendiendo!!!
  #4 (permalink)  
Antiguo 13/05/2014, 01:55
Avatar de MarioAraque
Colaborador
 
Fecha de Ingreso: octubre-2009
Ubicación: Valencia
Mensajes: 1.398
Antigüedad: 14 años, 5 meses
Puntos: 265
Respuesta: Problema al agregar nuevo contenido-nodo (El form se recarga y no guarda)

Fijate si hay algún error en la consola de javascript. Hay que ver alternativas porque con la información que tenemos no podemos resolver tu problema =(
  #5 (permalink)  
Antiguo 14/05/2014, 12:09
Avatar de anacona16  
Fecha de Ingreso: marzo-2010
Ubicación: Bogota DC
Mensajes: 610
Antigüedad: 14 años, 1 mes
Puntos: 52
Respuesta: Problema al agregar nuevo contenido-nodo (El form se recarga y no guarda)

Hola, al fin he resuelto el problema.

Después de agregar los path "node/add" y "node/*/edit" a los path no cacheados por varnish, el problema quedó resuelto.

Gracias.
__________________
Aprendiendo!!!

Etiquetas: form, node, recarga
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:42.