Foros del Web » Programación para mayores de 30 ;) » Programación General »

Dudas y asistencia con la Configuracion del cgi

Estas en el tema de Dudas y asistencia con la Configuracion del cgi en el foro de Programación General en Foros del Web. Hoy me registro nuevo en este foro y soy un poco novato en estas comunidades y tipo de trabajo, necesito ayuda para configurar mi script ...
  #1 (permalink)  
Antiguo 25/02/2014, 08:47
 
Fecha de Ingreso: febrero-2014
Ubicación: Puerto Rico
Mensajes: 1
Antigüedad: 10 años, 3 meses
Puntos: 0
Dudas y asistencia con la Configuracion del cgi

Hoy me registro nuevo en este foro y soy un poco novato en estas comunidades y tipo de trabajo, necesito ayuda para configurar mi script de FormMail en el servidor.

1. Me he bajado el Script de http://www.scriptarchive.com/ y subido al servidor configurado como indica abajo.

2. En la Primera línea del Script he puesto lo siguiente /usr/local/bin/perl
y tengo duda si es obligatorio poner siempre los caracteres #!, " ", ( ), ; en todo lo demás, me gustaría me aclararan eso.

3. En esta variable $mailprog = '/usr/sbin/sendmail'; he puesto esto.

4. En la variable @referers = ('midominio.com','211.1.210.113');
puse esto. El IP es un Ejemplo.

5. Lo subi al servidor como ASCII y con Permisos 755.

6. El Formulario que utilizo es el Siguiente,

<form method="POST" action="http://www.midominio.com/cgi-bin/FormMail.cgi">
<input type=hidden name="recipient" value="[email protected]">
<input type="hidden" name="redirect" value="http://www.dominio.com.com/Gracias.html">
<p><input type="text" name="author" id="author" value="" size="15" tabindex="1" />
<label for="author"><small>Nombre </small></label></p>
<p><input type="text" name="email" id="email" value="" size="15" tabindex="2" />
<label for="email"><small>Apellido</small></label></p>
<p><input type="text" name="url" id="url" value="" size="15" tabindex="3" />
<label for="url"><small>Email</small></label></p>

<!--<p><small><strong>XHTML:</strong> You can use these tags: <code>&lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;strike&gt; &lt;strong&gt; </code></small></p>-->
<p><textarea name="comment" id="comment" cols="25%" rows="5" tabindex="4"></textarea></p>
<p><input name="submit" type="submit" id="submit" tabindex="5" value="Enviar Comentario" />
<input type="reset" value=" Reset ">
</p>
</form>

7. Cuando he rellenado los campos del formulario y le doy enviar me sale el siguiente error y no se que esta mal

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

8. Llevo mucho tiempo rrompiendome la cabeza con esto y no logro que me funcione si alguien puede ayudarme agradeceré mucho, por favor y gracias de ante mano.

9. Conste que he leído los tutoriales de estos foros.

10. Son muchos los usuarios y participantes de este foro tan reconocido y prestigioso, por lo que espero alguien si pueda ayudarme de buena voluntad.

Última edición por compucellsystem; 26/02/2014 a las 22:24

Etiquetas: asistencia, cgi, dudas, perl
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:25.