Foros del Web » Programando para Internet » PHP » Configuración PHP »

instalar php

Estas en el tema de instalar php en el foro de Configuración PHP en Foros del Web. Hola a todos, quisiera saber si es posible instalar una versión de PHP más antigua a la que viene por defecto en un xampp, en ...
  #1 (permalink)  
Antiguo 12/01/2012, 06:38
Avatar de garciasanchezdani  
Fecha de Ingreso: noviembre-2011
Mensajes: 429
Antigüedad: 9 años, 6 meses
Puntos: 51
instalar php

Hola a todos, quisiera saber si es posible instalar una versión de PHP más antigua a la que viene por defecto en un xampp, en concreto tengo instalado xampp Version 1.6.8, con:

+ Apache 2.2.9
+ MySQL 5.0.67 (Community Server)
+ PHP 5.2.6

pero necesitaría bajar la versión de php, ya que necesito probar una web en local que tiene la versión de php 4.3.9 y que no es compatible con PHP 5.2.6

Enhorabuena al foro, que es de los mejores que he visitado.
Saludos
Daniel
  #2 (permalink)  
Antiguo 12/01/2012, 06:47
Avatar de Eleazan  
Fecha de Ingreso: abril-2008
Ubicación: Ibiza
Mensajes: 1.879
Antigüedad: 13 años, 1 mes
Puntos: 326
Respuesta: instalar php

Buenas

Si no recuerdo mal, esta versión de xampp venia con la 4.3.9
http://sourceforge.net/projects/xamp...Windows/1.4.9/

Supongo q se podrá "downgradear" manual... pero, me parece menos curro instalar una versión vieja de xampp xDD
__________________
>> Eleazan's Source
>> @Eleazan
  #3 (permalink)  
Antiguo 12/01/2012, 06:48
Avatar de fishdesign  
Fecha de Ingreso: abril-2011
Ubicación: Málaga
Mensajes: 389
Antigüedad: 10 años, 2 meses
Puntos: 95
Respuesta: instalar php

Pásate por aquí:
http://museum.php.net/
__________________
Web Designer.
Themes-Up!, próximamente
  #4 (permalink)  
Antiguo 12/01/2012, 06:54
Avatar de garciasanchezdani  
Fecha de Ingreso: noviembre-2011
Mensajes: 429
Antigüedad: 9 años, 6 meses
Puntos: 51
Respuesta: instalar php

Cita:
Iniciado por Eleazan Ver Mensaje
Buenas

Si no recuerdo mal, esta versión de xampp venia con la 4.3.9
http://sourceforge.net/projects/xamp...Windows/1.4.9/

Supongo q se podrá "downgradear" manual... pero, me parece menos curro instalar una versión vieja de xampp xDD
Hice lo que me dijiste, pero para este xampp no echan a andar ni mysql ni apache, y este xampp no tiene panel de control, y si intento arrancar apache y mysql mediante sus start.bat correspondientes, la consola no para y no me da tiempo a ver qué está pasando.
  #5 (permalink)  
Antiguo 12/01/2012, 06:56
Avatar de garciasanchezdani  
Fecha de Ingreso: noviembre-2011
Mensajes: 429
Antigüedad: 9 años, 6 meses
Puntos: 51
Respuesta: instalar php

Cita:
Iniciado por fishdesign Ver Mensaje
Pásate por aquí:
http://museum.php.net/
Gracias fishdesign, ¿pero sabes cómo instalar php en el directorio de xampp, o más bien, qué problemas puedo encontrarme?
  #6 (permalink)  
Antiguo 12/01/2012, 07:22
Avatar de Eleazan  
Fecha de Ingreso: abril-2008
Ubicación: Ibiza
Mensajes: 1.879
Antigüedad: 13 años, 1 mes
Puntos: 326
Respuesta: instalar php

Cita:
Iniciado por garciasanchezdani Ver Mensaje
Hice lo que me dijiste, pero para este xampp no echan a andar ni mysql ni apache, y este xampp no tiene panel de control, y si intento arrancar apache y mysql mediante sus start.bat correspondientes, la consola no para y no me da tiempo a ver qué está pasando.
Ejecutalos desde la consola de comandos para ver q te dicen!

Supongo q será una version "non-win7"... cuidado xD
__________________
>> Eleazan's Source
>> @Eleazan

Etiquetas: mysql, php
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:22.