Foros del Web » Programando para Internet » PHP » Configuración PHP »

No me interpreta el codigo, me lo devuelve integro. Cual es el problema?

Estas en el tema de No me interpreta el codigo, me lo devuelve integro. Cual es el problema? en el foro de Configuración PHP en Foros del Web. Hola compañeros, buenas tardes. Como conocedor del codigo HTML y CSS he decidido aprender a programar en el entorno AMP para incrementar mis capacidades de ...
  #1 (permalink)  
Antiguo 21/05/2010, 18:35
Avatar de RAZGRIZ24  
Fecha de Ingreso: septiembre-2009
Mensajes: 143
Antigüedad: 11 años, 11 meses
Puntos: 2
No me interpreta el codigo, me lo devuelve integro. Cual es el problema?

Hola compañeros, buenas tardes. Como conocedor del codigo HTML y CSS he decidido aprender a programar en el entorno AMP para incrementar mis capacidades de desarrollo Web.

He comenzado hoy y la verdad a primer golpe de vista parece un lenguage muy agradecido, simple y potente, pero ya me da problemas.

He realizado un script muy sencillo para comprobar que la configuracion entre Apache 2.2 y php 6 fuera correcta, he seguido los pasos que dice mi libro para configurarlo y al probar el php en localhost, no me devuelve el resultado sino que devuelve el codigo tal cual. A que puede deberse el fallo?

Por favor, tened en cuenta que he comenzado esta mañana, asi que porfa absteneos de tecnicismos

Adjunto el codigo:

<HTML>
<Head>
<Title>Php testing</title>
</Head>
<Body>
<?php
echo "<p> Si soy capaz de leer esto es que he realizado una configuración php correcta</p>";
?>
</Body>
</HTML>

Última edición por RAZGRIZ24; 21/05/2010 a las 19:16
  #2 (permalink)  
Antiguo 21/05/2010, 18:46
Avatar de maturano  
Fecha de Ingreso: enero-2010
Ubicación: /home/
Mensajes: 537
Antigüedad: 11 años, 6 meses
Puntos: 36
Respuesta: Novato patoso, que hago mal?

Es obvio que no te está interpretando el código PHP, esto será porque no está siendo cargado el módulo en Apache.

Dices que estás siguiendo un libro, quizá en la parte de la instalación te pidió que modificaras el archivo httpd.conf --para agregar el soporte de PHP--; cada que edites una configuración de Apache y de PHP --el archivo php.ini-- deberás reiniciar Apache. ¿Lo hiciste?.

No dejar de comentar que PHP6 aún no existe. La versión actual de PHP es PHP 5.3, la diferencia con PHP6 (aún en desarrollo) sería, básicamente, el soporte de Unicode, pero aún así, esos libros de PHP6 ... bueno, me parece ridículo; están vendiendo algo que no existe.

Por último, si vas a comenzar con la programación, mi sugerencia es que no te preocupes por la configuración e instalación. Existen paquetes que te instalan todo lo necesario para preocuparte solo por programar, por aprender el lenguaje. Mi sugerencia, XAMPP
http://www.apachefriends.org/en/xampp.html


Ah ... y pésimo título. Por favor, para la próxima, se más descriptivo.
__________________
I ♥ The Music!
  #3 (permalink)  
Antiguo 21/05/2010, 19:16
Avatar de RAZGRIZ24  
Fecha de Ingreso: septiembre-2009
Mensajes: 143
Antigüedad: 11 años, 11 meses
Puntos: 2
Respuesta: Novato patoso, que hago mal?

Cita:
Iniciado por maturano Ver Mensaje
Es obvio que no te está interpretando el código PHP, esto será porque no está siendo cargado el módulo en Apache.

Dices que estás siguiendo un libro, quizá en la parte de la instalación te pidió que modificaras el archivo httpd.conf --para agregar el soporte de PHP--; cada que edites una configuración de Apache y de PHP --el archivo php.ini-- deberás reiniciar Apache. ¿Lo hiciste?.

No dejar de comentar que PHP6 aún no existe. La versión actual de PHP es PHP 5.3, la diferencia con PHP6 (aún en desarrollo) sería, básicamente, el soporte de Unicode, pero aún así, esos libros de PHP6 ... bueno, me parece ridículo; están vendiendo algo que no existe.

Por último, si vas a comenzar con la programación, mi sugerencia es que no te preocupes por la configuración e instalación. Existen paquetes que te instalan todo lo necesario para preocuparte solo por programar, por aprender el lenguaje. Mi sugerencia, XAMPP
http://www.apachefriends.org/en/xampp.html


Ah ... y pésimo título. Por favor, para la próxima, se más descriptivo.
Si configuré el php.ini y el httpd.config y reinicie apache.

El tema del PHP, originalmente descargue el 5.3, pero instale el 6 porque a la hora de configurar me volvia loco, los nombres de archivo no coincidian y me daba error constantemente. Con respecto a lo de xxamp, lo tengo, pero me no suelo saltarme las versiones de los libros por miedo a que luego pidan alguna utilidad o comando especifico y a mi eso me afecte, de todos modos si me recomiendas el xxamp lo pondre en practica.

Ahora cambiarle el titulo.

Gracias pro responder!! :D

Etiquetas: Ninguno
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:07.