Foros del Web » Programando para Internet » PHP » Configuración PHP »

Problemas al actualizar e instalar php 5.3.8

Estas en el tema de Problemas al actualizar e instalar php 5.3.8 en el foro de Configuración PHP en Foros del Web. Tengo instalado Php 5.2.3, necesito actualizar a Php 5.3.8 o una versión que me permita trabajar con Symfony en Win XP o Vista. Tengo instalado ...
  #1 (permalink)  
Antiguo 10/11/2011, 18:10
 
Fecha de Ingreso: noviembre-2011
Mensajes: 1
Antigüedad: 9 años, 7 meses
Puntos: 0
Problemas al actualizar e instalar php 5.3.8

Tengo instalado Php 5.2.3, necesito actualizar a Php 5.3.8 o una versión que me permita trabajar con Symfony en Win XP o Vista.

Tengo instalado Apache 2.2.4

Descargue el archivo Installer (38.31MB) de la version Php 5.3(5.3.8) desde: http://windows.php.net/download/

Ejecute el instalador y termino la instalación sin problemas, pero al querer abrir un archivo php desde el browser este no se puede ver y aparece la opción para descargar el archivo.

En la versión de Php 5.2.3 durante la instalacion me pedía indicar: Apache2.2xModule e indicar la ruta del archivo “conf”…. en la instalación de la versión php 5.3.8 no lo pide…

¿Alguien me puede ayudar o indicarme como instalar php 5.3.8 correctamente?

Saludos

Mauricio
  #2 (permalink)  
Antiguo 11/11/2011, 09:54
Avatar de abimaelrc
Colaborador
 
Fecha de Ingreso: mayo-2009
Ubicación: En el planeta de Puerto Rico
Mensajes: 14.734
Antigüedad: 12 años
Puntos: 1517
Respuesta: Problemas al actualizar e instalar php 5.3.8

Esto es importante
Cita:
Iniciado por http://windows.php.net/download/
Which version do I choose?
If you are using PHP with Apache 1 or Apache2 from apache.org you need to use the VC6 versions of PHP


If you are using PHP with IIS you should use the VC9 versions of PHP

VC6 Versions are compiled with the legacy Visual Studio 6 compiler

VC9 Versions are compiled with the Visual Studio 2008 compiler and have improvements in performance and stability. The VC9 versions require you to have the Microsoft 2008 C++ Runtime (x86) or the Microsoft 2008 C++ Runtime (x64) installed

Do NOT use VC9 version with apache.org binaries

VC9 versions of Apache can be fetched at Apache Lounge. We use their binaries to build the Apache SAPIs.
Eso quiere decir que la versión 5.3.x es en vc9 y no están brindando la de vc6. Por lo que tienes o compilar apache en versión vc9 o buscar una versión vc9 de apache, ya que apache está compilado en vc6 o usar algún instalador como por ejemplo Zend Server CE, que ya tiene esas versiones http://www.zend.com/en/products/server-ce/downloads
__________________
Verifica antes de preguntar.
Los verdaderos amigos se hieren con la verdad, para no perderlos con la mentira. - Eugenio Maria de Hostos

Etiquetas: php
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:37.