Foros del Web » Programando para Internet » ASP Clásico »

CDonts en XP

Estas en el tema de CDonts en XP en el foro de ASP Clásico en Foros del Web. Por alguna razon que desconozco la gente de Miscrosoft decidio no Incluir la libreria CDonts en el IIS 5.1 que viene con el Windows XP ...

  #1 (permalink)  
Antiguo 22/04/2002, 14:00
Avatar de g_susdaniel  
Fecha de Ingreso: mayo-2001
Ubicación: Frente al Monitor :þ
Mensajes: 995
Antigüedad: 23 años, 1 mes
Puntos: 0
CDonts en XP

Por alguna razon que desconozco la gente de Miscrosoft decidio no Incluir la libreria CDonts en el IIS 5.1 que viene con el Windows XP Professional. Yo tuve 2 dias luchando con este problemilla y di con la solucion, ahora quiero comentarsela para que se eviten esto...

La manera de trabajar con CDonts con el IIS 5.1 que trae el XP, es...

1.- Buscas de Otra makina el cdonts.dll o la bajas de http://www.geocities.com/g_susdaniel/cdonts.zip
2.- La extraes y/o colocas en el directorio C:\WINDOWS\system32
3.- La Registras, arrastrando (Drag & drop) el archivo cdonts.dll hasta colocarlo sobre el archivo: regsvr32.exe y te saldra un Mensaje diciendo que fue registrada la libreria con exito...

Te vas por "Inicio" -> "Ejecutar" y tecleas regsvr32 cdonts.dll | igualmente se registra.

Luego de esto puedes usar la libreria CDonts sin problemas, bueno asi la he usado yo ;)

Usuario # 3359 en los foros

Última edición por g_susdaniel; 06/12/2002 a las 02:46
  #2 (permalink)  
Antiguo 02/06/2002, 23:24
Avatar de urjose  
Fecha de Ingreso: diciembre-2001
Mensajes: 5.286
Antigüedad: 22 años, 5 meses
Puntos: 1
Re: CDonts en XP

Excelente !, Soy feliz por que con este tip jalo.

Así que sube , sube...

Thanx por el tip
  #3 (permalink)  
Antiguo 03/06/2002, 14:36
 
Fecha de Ingreso: enero-2002
Mensajes: 141
Antigüedad: 22 años, 5 meses
Puntos: 0
Re: CDonts en XP

daniel, gracias por tu excelente dato,
urjose y yo estabamos dandonos cabezasos, solo que a el le funciono y a mi no, a mi no me da ningun mensaje de error pero deja los mensajes en la cola de entrega y nunca los envia o pasa a correo malo?????,

tiene alguien idea de como resolverlo ?
  #4 (permalink)  
Antiguo 03/06/2002, 17:56
 
Fecha de Ingreso: mayo-2002
Mensajes: 24
Antigüedad: 22 años
Puntos: 0
Re: CDonts en XP

urjose si quieres te la envio por email, yo la uso tambien, y la tengo.
  #5 (permalink)  
Antiguo 03/06/2002, 21:05
 
Fecha de Ingreso: enero-2002
Ubicación: Perez Zeledon Costa Rica
Mensajes: 1.009
Antigüedad: 22 años, 5 meses
Puntos: 11
Re: CDonts en XP

Jose.
Si andas por aqui, tengo algo raro con aquello, podrias ICQarte.
;)
  #6 (permalink)  
Antiguo 04/06/2002, 06:01
Avatar de Ruchu  
Fecha de Ingreso: octubre-2001
Mensajes: 698
Antigüedad: 22 años, 8 meses
Puntos: 2
Re: CDonts en XP

por fin!!

yo tambien me volvi loco, no entendia como el iis del xp no funcionaba el cdonts!

gracias. :P
  #7 (permalink)  
Antiguo 17/07/2002, 10:20
 
Fecha de Ingreso: noviembre-2001
Ubicación: Manta Ecuador
Mensajes: 200
Antigüedad: 22 años, 7 meses
Puntos: 0
Re: CDonts en XP

Al fin,

Gracias
  #8 (permalink)  
Antiguo 13/06/2003, 07:59
 
Fecha de Ingreso: mayo-2003
Mensajes: 101
Antigüedad: 21 años, 1 mes
Puntos: 0
He hecho lo de registrar la librería cdonts y el hecho es que en la página no me sale ningun error, hay q configurar de alguna forma en especial el servicio smtp de iss o se deja por defecto ?

Gracias
  #9 (permalink)  
Antiguo 21/07/2003, 23:18
Avatar de mamon  
Fecha de Ingreso: enero-2002
Ubicación: Lima
Mensajes: 1.302
Antigüedad: 22 años, 5 meses
Puntos: 3
Ya hice lo q dijiste g_susdaniel pero aun no puedo usar el CDONT... fácil el código está malo... lo puedes ver?

<%
Para = "[email protected]"
Asunto = "Hola"
HTML = "Rafa :D"
Set myMail = Server.CreateObject( "CDONTS.Newmail" )
myMail.BodyFormat = 0
myMail.MailFormat = 0
myMail.From = "[email protected]"
myMail.To = Para
myMail.Subject = Asunto
myMail.Body = HTML
myMail.Send
Set myMail = Nothing
%>
__________________
Yo si sé lo que es trabajar duro, porque lo he visto.
  #10 (permalink)  
Antiguo 11/10/2003, 10:42
 
Fecha de Ingreso: febrero-2003
Mensajes: 101
Antigüedad: 21 años, 4 meses
Puntos: 0
Hola, podriais mandarme un ejemplo de como hacer un formulario en asp y que se envien los datos? es que siempre que va a crear el objeto me sale error.

Saludos
  #11 (permalink)  
Antiguo 18/11/2003, 18:26
 
Fecha de Ingreso: noviembre-2003
Mensajes: 13
Antigüedad: 20 años, 7 meses
Puntos: 0
Gracias tronco por la información acerca de CDONTS en XP.

Mu guena esa.
  #12 (permalink)  
Antiguo 18/11/2003, 18:30
 
Fecha de Ingreso: noviembre-2003
Mensajes: 13
Antigüedad: 20 años, 7 meses
Puntos: 0
Para el chaval de lima de alias mamon

Yo lo hago así y funciona mira:

formulario=request.form("formulario")

formulario = Replace(vcurriculum,vbCrLf,"<BR>")
texto= "<font color=#0000FE>" & formulario & "</font>"
Set Mail = Server.CreateObject ("CDONTS.Newmail")
Mail.BodyFormat=0
Mail.MailFormat=0
Mail.From = "[email protected]"
Mail.To = "[email protected]"
Mail.Subject = "recibir informacion"
Mail.Body = texto
Mail.Send
Set Mail = Nothing
response.write"Biennn uhhh.."
%>
  #13 (permalink)  
Antiguo 21/11/2003, 13:18
 
Fecha de Ingreso: mayo-2003
Ubicación: Catalunya
Mensajes: 30
Antigüedad: 21 años, 1 mes
Puntos: 0
Pues a mi sigue sin funcionarme :( a pesar de seguir todos los pasos sin que nada de errores. El mail nunca llega.


  #14 (permalink)  
Antiguo 21/11/2003, 13:21
 
Fecha de Ingreso: mayo-2003
Ubicación: Catalunya
Mensajes: 30
Antigüedad: 21 años, 1 mes
Puntos: 0
Exclamación OSTIA

Funciona siempre, excepto cuando el dominio que recibe es @hotmail.com


que putada no?
  #15 (permalink)  
Antiguo 23/02/2004, 08:00
 
Fecha de Ingreso: enero-2002
Mensajes: 1.438
Antigüedad: 22 años, 5 meses
Puntos: 0
a mi me va pera hotmail, pero no para lycos

pq, pues no lo se
  #16 (permalink)  
Antiguo 26/02/2004, 05:34
 
Fecha de Ingreso: julio-2002
Ubicación: stgo rec
Mensajes: 438
Antigüedad: 21 años, 10 meses
Puntos: 3
Holas

YO uso WinXP Pro y tb uso el Cdonts para en envio de los email, hay alguna razon por la cual algunos correos no son enviados en el acto, en algunos casos pasa 1 dia y lo envia. nose si sera concidencia pero yo en mi outlook tengo configuradas 2 cuantas de correo las 2 son pop una es vtr.net y la otra yahoo.es y a estos email llegan imediatamentes pero a otra que es hotmail.com no.

Saludos
__________________
Saludos
Leo
  #17 (permalink)  
Antiguo 02/08/2004, 03:40
Avatar de engonga
Usuario no validado
 
Fecha de Ingreso: marzo-2002
Ubicación: Buenos Aires
Mensajes: 1.300
Antigüedad: 22 años, 3 meses
Puntos: 8
si si pero...

si pero cuando el servidor que usas para hostar la web esta en windows 2003 y no es tuyo si no que es de una empresa como arsys o lo que sea. No existe algun cdonts para windows 2003?

a mi me han dicho que prueve con aspmail....


pero no se
  #18 (permalink)  
Antiguo 02/08/2004, 04:12
 
Fecha de Ingreso: mayo-2003
Ubicación: Catalunya
Mensajes: 30
Antigüedad: 21 años, 1 mes
Puntos: 0
Si el servidor es de una empresa como arsys, son ellos quienes deben proveerte de una solución.
  #19 (permalink)  
Antiguo 02/08/2004, 13:26
Avatar de engonga
Usuario no validado
 
Fecha de Ingreso: marzo-2002
Ubicación: Buenos Aires
Mensajes: 1.300
Antigüedad: 22 años, 3 meses
Puntos: 8
...si pero

pero no existe un cdonts para el iss del windows 2003 server?
  #20 (permalink)  
Antiguo 02/08/2004, 14:22
Avatar de Myakire
Colaborador
 
Fecha de Ingreso: enero-2002
Ubicación: Centro de la república
Mensajes: 8.849
Antigüedad: 22 años, 4 meses
Puntos: 146
vaya, este post espezo en Abril del 2002, y aun hay gente (yo incluido) que participa; eso es vigencia. jejeje
Saludos
  #21 (permalink)  
Antiguo 15/08/2004, 17:31
Avatar de mamon  
Fecha de Ingreso: enero-2002
Ubicación: Lima
Mensajes: 1.302
Antigüedad: 22 años, 5 meses
Puntos: 3
lo q pasa q es un problema eso de enviar mails con ASP.. xq necesitas tener algo instalado=S q bad!
__________________
Yo si sé lo que es trabajar duro, porque lo he visto.
  #22 (permalink)  
Antiguo 31/08/2004, 05:34
Avatar de Joselete  
Fecha de Ingreso: septiembre-2001
Ubicación: Granada, España
Mensajes: 263
Antigüedad: 22 años, 9 meses
Puntos: 0
Muchisimas gracias, se resolvió mi problema ;)
__________________
"El Universo simpre quiere que ganemos"
  #23 (permalink)  
Antiguo 11/02/2005, 01:55
Avatar de mamon  
Fecha de Ingreso: enero-2002
Ubicación: Lima
Mensajes: 1.302
Antigüedad: 22 años, 5 meses
Puntos: 3
he leido en otros post q se necesita ocmo un certificado para que lleguen los mails a hotmail, y preguntaban donde podían conseguirlo, nadie le respondió. Pero puede ser q sea cierto, xq yo tp lo puedo enviar a hotmail... q tonteria no? osea el IIS y el CDONT son de microsoft, el hotmail tambien... nos deberían de dar alguna ventaja x eso... q llegue antes o no sé!
__________________
Yo si sé lo que es trabajar duro, porque lo he visto.
  #24 (permalink)  
Antiguo 17/03/2005, 11:06
Avatar de g_susdaniel  
Fecha de Ingreso: mayo-2001
Ubicación: Frente al Monitor :þ
Mensajes: 995
Antigüedad: 23 años, 1 mes
Puntos: 0
Cita:
Iniciado por mamon
he leido en otros post q se necesita ocmo un certificado para que lleguen los mails a hotmail, y preguntaban donde podían conseguirlo, nadie le respondió. Pero puede ser q sea cierto, xq yo tp lo puedo enviar a hotmail... q tonteria no? osea el IIS y el CDONT son de microsoft, el hotmail tambien... nos deberían de dar alguna ventaja x eso... q llegue antes o no sé!
jajaja si DEBERIAN, pero a ellos por saludarlos hay que pagarles, ya lo sabes ... va para 3 años q puse el msj inicial y aun vive xD ... creo q ya es hora de ir migrando a .NET ;) ...
  #25 (permalink)  
Antiguo 20/04/2005, 11:07
 
Fecha de Ingreso: abril-2005
Mensajes: 70
Antigüedad: 19 años, 2 meses
Puntos: 0
Que hago ??

Amigos este problema me va a explotar la cabeza, yo uso Windows Server 2003, el no traía la dll CDONTS, la descargue y la instalé y desde mi pagina trato de enviar un email, al parecer el código no tiene ningún problema, no me da error, pero jamás envía un mensaje, no se si será por la configuración del IIS. El servidor al que mando los correos es mió, corre sobre MDaemon. Por favor alguien pudiera decirme que me pasa, cómo puedo lograr solucionar este problema ?
  #26 (permalink)  
Antiguo 20/04/2005, 22:59
Avatar de mamon  
Fecha de Ingreso: enero-2002
Ubicación: Lima
Mensajes: 1.302
Antigüedad: 22 años, 5 meses
Puntos: 3
jajajaja.. si.. eso de que no llega el mail es seguro x la seguridad del correo a donde has enviado el mail... me rio xq tiene razón g_susdaniel, hace como 3 años que está este mensaje, es más.. yo soy uno de los que puso los primeros post... el .NET es una nueva programación con menos problemas como esos que tiene ASP, que necesitamos más permisos, componentes, etc... ya me compré mi libro de .NET será para ya ir imigrando.. jejeejje.. saludos a todos
__________________
Yo si sé lo que es trabajar duro, porque lo he visto.
  #27 (permalink)  
Antiguo 21/04/2005, 02:50
Avatar de engonga
Usuario no validado
 
Fecha de Ingreso: marzo-2002
Ubicación: Buenos Aires
Mensajes: 1.300
Antigüedad: 22 años, 3 meses
Puntos: 8
y que libro es

mamon

passa referencias de tu libro que yo tambien me quiero comprar uno y no se cual comprar.

gracias
  #28 (permalink)  
Antiguo 27/04/2005, 09:42
Avatar de g_susdaniel  
Fecha de Ingreso: mayo-2001
Ubicación: Frente al Monitor :þ
Mensajes: 995
Antigüedad: 23 años, 1 mes
Puntos: 0
Particularmente en su momento compré :

Microsoft ASP.NET aprenda ya
G. Andrew Duthie
McGraw-Hill
Microsoft

en las faqs del foro de .NET hay buenos tutoriales tambien... saludos
__________________
No, no no... no hay firma...
  #29 (permalink)  
Antiguo 31/05/2005, 08:25
 
Fecha de Ingreso: mayo-2005
Mensajes: 5
Antigüedad: 19 años
Puntos: 0
Buenas, yo tenia el mismoproblema con el cdonts, me lo baje y registre siguiendo los pasos de g_susdaniel, hasta hay fenomenal, ahora me da un error de permisos.
Si alguien a tenido el mismo problema y lo ha solucionado me haria un favor explicandomelo, gracias.

Tipo de error:
Objeto Server, ASP 0178 (0x80070005)
Error en la llamada a Server.CreateObject al comprobar permisos. Se ha denegado el acceso a este objeto.
/infotrol/ADMIN/ENCUESTAS/prueba3.asp, línea 3

linea 3: Set Mail = Server.CreateObject ("CDONTS.Newmail")
  #30 (permalink)  
Antiguo 31/05/2005, 08:43
 
Fecha de Ingreso: mayo-2005
Mensajes: 5
Antigüedad: 19 años
Puntos: 0
Aqui la opcion para los que se desquicien con cdonts.
(Encontre rapida solucion.)
espero que os sea util:

Set objMessage = CreateObject("CDO.Message")
objMessage.Subject = "Email de prueba desde pagina asp"
objMessage.Sender = "[email protected]"
objMessage.To = "[email protected]"
ObjMessage.HTMLBody ="Esto es una prueba para ver si llega el email con CDOSYS"
objMessage.Send
set objmessage=nothing
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta

SíEste tema le ha gustado a 2 personas (incluyéndote)




La zona horaria es GMT -6. Ahora son las 20:17.