Foros del Web » Programando para Internet » PHP »

[SOLUCIONADO] Problema Ioncube + FastCGI

Estas en el tema de Problema Ioncube + FastCGI en el foro de PHP en Foros del Web. Hola, Acabo de cambiar mis servidores para funcionar desde apache a nginx. Lo primero que tenía que hacer para usar nginx con php era instalar ...
  #1 (permalink)  
Antiguo 01/07/2014, 12:32
Avatar de adrianesx  
Fecha de Ingreso: febrero-2013
Mensajes: 4
Antigüedad: 11 años, 3 meses
Puntos: 0
Problema Ioncube + FastCGI

Hola,

Acabo de cambiar mis servidores para funcionar desde apache a nginx.

Lo primero que tenía que hacer para usar nginx con php era instalar fastcgi (el paquete php5-fpm).

Todo esto bien, en todos mis servidores va de lujo, y nginx comparado con apache sirve a velocidad de un tiro.

¿El problema? En un vserver uso un script php prefabricado que va codificado y funciona con ioncube, pero no sé por qué no funciona bien, especialmente cuando tengo mezclado en un mismo php archivos codificados que venian prefrabricados insertados en php propios (p.ej.: desde un php propio hago la llamada con require_once()), en unos funciona el decodificado pero lo que no está decodificado lo escupe sin interpretar php, en otros no interpreta nada de php... un jaleo raro.

Como digo, cuando el php es puramente codificado para ioncube o puramente sin codificar va bien.

¿Alguien tiene idea de qué pasa? Ahora mismo le tengo que pasar los archivos php a apache para que funcione en ese servidor. Va bastante mejor que apache en solitario pero preferiría prescindir de apache y pasar los php por fastcgi.

Gracias de antemano. Si esta en la categoría que no es decídmelo.

Edito: Se me olvidaba decir que la máquina es un VPS con debian 6:

Kernel and CPU Linux 2.6.32-042stab090.3 on i686
Processor information Intel(R) Core(TM) i7-4771 CPU @ 3.50GHz, 3 cores

Última edición por adrianesx; 01/07/2014 a las 12:43 Razón: Olvide dar datos
  #2 (permalink)  
Antiguo 01/07/2014, 13:04
Avatar de adrianesx  
Fecha de Ingreso: febrero-2013
Mensajes: 4
Antigüedad: 11 años, 3 meses
Puntos: 0
Respuesta: Problema Ioncube + FastCGI

Madre mía, que error más tonto... en fin lo pongo por si a alguien le pasa.

Al cambiar a fastcgi, usas un archivo php.ini distinto, obviamente, pero si no caes, te pasa esta tontería.

Y el nuevo archivo php.ini no tenía habilitado la opción short open tags y tooooodos mis scripts propios abren el php con <? únicamente en vez de <?php.

Si no usas short open tags ni te pasa esto, así que nada, un saludo.

Etiquetas: fastcgi, ioncube
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:13.