Foros del Web » Programando para Internet » PHP »

Siempre funciono, pero ahora no me tira

Estas en el tema de Siempre funciono, pero ahora no me tira en el foro de PHP en Foros del Web. Siempre me funciono esta chapucilla, que basicamente coge todos los valores por post que envio desde la hoja anterior. Ahora parece no funcionar, y si ...
  #1 (permalink)  
Antiguo 27/04/2010, 10:33
 
Fecha de Ingreso: abril-2002
Mensajes: 33
Antigüedad: 22 años
Puntos: 0
Siempre funciono, pero ahora no me tira

Siempre me funciono esta chapucilla, que basicamente coge todos los valores por post que envio desde la hoja anterior. Ahora parece no funcionar, y si imprimo la query me sale así de fea:


$valor=20 //las filas

for($irrr=0;$irrr<$valor;$irrr++){

$descuentoinstalador='$_POST[descuentoinstalador'.$irrr.']';
$codprod='$_POST[codprod'.$irrr.']';

$Queryq ="update productos set descuentoinstalador=".$descuentoinstalador." where codprod=".$codprod;
print $Queryq.'<br>';
$IdConsultaq = mysql_query($Queryq, $IdConexion);


}


Y ahora me da este resultado en lugar de los valores me aparece el $,

update productos set descuentoinstalador=$_POST[descuentoinstalador0] where codprod=$_POST[codprod0]
update productos set descuentoinstalador=$_POST[descuentoinstalador1] where codprod=$_POST[codprod1]


No se por donde entrar, por lo que pruebo el foro nuevamente.
1000 gracias!!!
__________________
Sergio Sánchez
www.sergio.es
  #2 (permalink)  
Antiguo 27/04/2010, 10:47
 
Fecha de Ingreso: febrero-2010
Mensajes: 818
Antigüedad: 14 años, 2 meses
Puntos: 55
Respuesta: Siempre funciono, pero ahora no me tira

le estas asignando una cadena no el valor POST de la variable sácale las comillas.
Código PHP:
$descuentoinstalador='$_POST[descuentoinstalador'.$irrr.']';

asi

$descuentoinstalador
=$_POST['descuentoinstalador'.$irrr]; 
o puedes directamente meterl el post[] en la consulta sin pasarlas antes a otra variable
  #3 (permalink)  
Antiguo 27/04/2010, 11:14
 
Fecha de Ingreso: abril-2002
Mensajes: 33
Antigüedad: 22 años
Puntos: 0
Respuesta: Siempre funciono, pero ahora no me tira

Genial, muchisimas gracias por abrir los ojos a un ciego.

Pues me tenía la cabeza consumida.....
__________________
Sergio Sánchez
www.sergio.es

Etiquetas: siempre, tira
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:41.