Foros del Web » Programación para mayores de 30 ;) » .NET »

elegir framework para compilar

Estas en el tema de elegir framework para compilar en el foro de .NET en Foros del Web. Hola buenas Tardes! El escenario es el siguiente: Quiero compilar un poryecto de librerías que tiene un clase (que no utiliza ningún componente que no ...
  #1 (permalink)  
Antiguo 13/03/2009, 13:20
Avatar de Javier01  
Fecha de Ingreso: febrero-2008
Ubicación: Montevideo
Mensajes: 261
Antigüedad: 13 años, 5 meses
Puntos: 31
elegir framework para compilar

Hola buenas Tardes!
El escenario es el siguiente:
Quiero compilar un poryecto de librerías que tiene un clase
(que no utiliza ningún componente que no este incluído en el framework 1.1),
en el equipo en que trabajo tiene instaladas las versiones 2.0 y 1.1 del .net framework
y quiero indicarle al compilador que genere la dll para el framework 1.1.
Leí algo por ahi de incluír una línea en un archivo de configuración indicando la versión del framework pero no resulta.
¿Alguna ayuda?
Gracias!
  #2 (permalink)  
Antiguo 13/03/2009, 15:11
Avatar de gedarufi  
Fecha de Ingreso: diciembre-2008
Ubicación: Colombia
Mensajes: 540
Antigüedad: 12 años, 8 meses
Puntos: 22
Respuesta: elegir framework para compilar

Como lo estas compilando, porque solo la versión 2008 te permite generar los ensamblados para las diferentes versiones de Framework existentes, para eso le das click derecho al proyecto y luego seleccionas propiedades y en donde dice Target Framework seleccionas el que mejor te venga.
  #3 (permalink)  
Antiguo 25/03/2009, 11:11
Avatar de Javier01  
Fecha de Ingreso: febrero-2008
Ubicación: Montevideo
Mensajes: 261
Antigüedad: 13 años, 5 meses
Puntos: 31
De acuerdo Respuesta: elegir framework para compilar

Perdón por la demora del agradecimiento!
y Gracias por la respuesta! y lo resolví así como dice tu respuesta!

Otra manera que encontré fue con una herramienta de M$ algo como, msbuild o
algo así, que es por consola, y te deja compilar de distintas versiones!

Otra forma (descartada por caer muy baja!) es instalar el la versión 2003 del .net, que este si compila con el framework 1.1!

bueno saludos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:18.