Foros del Web » Programación para mayores de 30 ;) » .NET »

Problema al utilizar función de una clase desde Page Method

Estas en el tema de Problema al utilizar función de una clase desde Page Method en el foro de .NET en Foros del Web. Hola, en mi site estoy implimentando un formulario de login. Para comprobar que el usuario existe llamo desde jquery a un page method. El problema ...
  #1 (permalink)  
Antiguo 05/09/2011, 07:28
 
Fecha de Ingreso: mayo-2011
Mensajes: 60
Antigüedad: 13 años, 2 meses
Puntos: 1
Problema al utilizar función de una clase desde Page Method

Hola, en mi site estoy implimentando un formulario de login. Para comprobar que el usuario existe llamo desde jquery a un page method. El problema que tengo es que siempre me devuelve un error incluso cuando introduzco un usuario y su clave correctamente. Después de debugar he podido descubrir en que línea me falla. La cuestión es que esta línea de código se encuentra en una clase (a la cual llamo desde mi page method).
Para comprobar su correcto funcionamiento he creado también una aspx para pruebas, y en esta (que no es un web method) si que me hace bien el encriptar y decriptar (en esta imagen se pueden ver los datos encriptados y desencriptados http://imageshack.us/photo/my-images/14/encdec.jpg/)
La línea en la que me falla mi código es esta: cs.Close(), justo cuando la ejecuta.
También he probado a jarcodear la clave, entonces el código funciona perfectamente, pero si tiene que desencriptar no funciona.
Para poder hacer el código he seguido las instrucciones de: http://www.codeproject.com/KB/securi...NetCrypto.aspx
¿Alguna idea de por qué sucede esto? Muchas gracias por adelantado.
  #2 (permalink)  
Antiguo 05/09/2011, 11:56
 
Fecha de Ingreso: agosto-2011
Ubicación: Buenos Aires
Mensajes: 78
Antigüedad: 12 años, 11 meses
Puntos: 10
Respuesta: Problema al utilizar función de una clase desde Page Method

¿El error entonces es de encriptación?
__________________
www.orientadoanet.com
  #3 (permalink)  
Antiguo 06/09/2011, 00:59
 
Fecha de Ingreso: mayo-2011
Mensajes: 60
Antigüedad: 13 años, 2 meses
Puntos: 1
Respuesta: Problema al utilizar función de una clase desde Page Method

Pues la verdad que no lo se, porqué no me funciona realizando la llamada desde un webmethond, sin embargo la llamada desde una función o un procedimiento normal me realiza perfectamente la encriptación y desencriptación. Seguiré investigando a ver. Gracias.
  #4 (permalink)  
Antiguo 06/09/2011, 02:00
 
Fecha de Ingreso: mayo-2011
Mensajes: 60
Antigüedad: 13 años, 2 meses
Puntos: 1
Respuesta: Problema al utilizar función de una clase desde Page Method

Hola, al final he resuelto el problema. La función cifra y descifra bien. El error era mio que en vez de descifrar tenía que cifrar una campo. Por eso los valores no eran los mismos. Lo he visto al volver a debugar y ver que los valores cifrados eran diferentes.

Etiquetas: clase, method, net, page
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 18:02.