Foros del Web » Administración de Sistemas » Unix / Linux »

Problemas para habilitar php-ldap en centos 6

Estas en el tema de Problemas para habilitar php-ldap en centos 6 en el foro de Unix / Linux en Foros del Web. hola amigos, tengo instalado php 5.5.27 en centos 6 y necesito que una aplicación se pueda autenticar con ldap con el siguiente codigo estoy verificando ...
  #1 (permalink)  
Antiguo 18/08/2015, 09:20
 
Fecha de Ingreso: septiembre-2010
Mensajes: 1.853
Antigüedad: 13 años, 6 meses
Puntos: 6
Problemas para habilitar php-ldap en centos 6

hola amigos, tengo instalado php 5.5.27 en centos 6 y necesito que una aplicación se pueda autenticar con ldap

con el siguiente codigo estoy verificando si php se esta conectando
Código PHP:
Ver original
  1. $ldaphost = "ldaps:/server";
  2.  
  3. // Conexión al servidor LDAP
  4. $ldapconn = ldap_connect($ldaphost)
  5.        or die("Could not connect to {$ldaphost}");

pero obtengo el siguiente error

Call to undefined function ldap_connect()

comprobe si tengo instalado y obtengo

Código BASH:
Ver original
  1. # php -m |grep ldap
  2. #

Última edición por Montes28; 18/08/2015 a las 09:38
  #2 (permalink)  
Antiguo 18/08/2015, 10:48
Avatar de lauser
Moderator Unix/Linux
 
Fecha de Ingreso: julio-2013
Ubicación: Odessa (Ukrania)
Mensajes: 3.278
Antigüedad: 10 años, 8 meses
Puntos: 401
Respuesta: Problemas para habilitar php-ldap en centos 6

Comprueba si la tienes agregada en php.ini:
extension=ldap.so

Si no, ya sabes...
Código BASH:
Ver original
  1. nano /etc/php.ini
__________________
Los usuarios que te responden, lo hacen altruistamente y sin ánimo de lucro con el único fin de ayudarte. Se paciente y agradecido.
-SOLOLINUX-
  #3 (permalink)  
Antiguo 18/08/2015, 19:06
 
Fecha de Ingreso: septiembre-2010
Mensajes: 1.853
Antigüedad: 13 años, 6 meses
Puntos: 6
Respuesta: Problemas para habilitar php-ldap en centos 6

lauser gracias por responder, me funciono.
  #4 (permalink)  
Antiguo 19/08/2015, 01:16
Avatar de lauser
Moderator Unix/Linux
 
Fecha de Ingreso: julio-2013
Ubicación: Odessa (Ukrania)
Mensajes: 3.278
Antigüedad: 10 años, 8 meses
Puntos: 401
Respuesta: Problemas para habilitar php-ldap en centos 6

Me alegro Montes28.
De hoy en adelante recuerda cuando instales una nueva extensión comprobar el php.ini.
__________________
Los usuarios que te responden, lo hacen altruistamente y sin ánimo de lucro con el único fin de ayudarte. Se paciente y agradecido.
-SOLOLINUX-
  #5 (permalink)  
Antiguo 19/08/2015, 10:47
 
Fecha de Ingreso: septiembre-2010
Mensajes: 1.853
Antigüedad: 13 años, 6 meses
Puntos: 6
Respuesta: Problemas para habilitar php-ldap en centos 6

lauser gracias por responder, tambien he visto que el php 5.3.3 que viene en centos coloca problemas para actualizar el php o las extensiones
  #6 (permalink)  
Antiguo 19/08/2015, 14:30
Avatar de lauser
Moderator Unix/Linux
 
Fecha de Ingreso: julio-2013
Ubicación: Odessa (Ukrania)
Mensajes: 3.278
Antigüedad: 10 años, 8 meses
Puntos: 401
Respuesta: Problemas para habilitar php-ldap en centos 6

Si estas usando centos 6.x,,,,,,, realiza un update, pero ya. Ya lanzaron la 6.7 que viene con el php 5.4.41 y un monton de mejoras interesantes.
__________________
Los usuarios que te responden, lo hacen altruistamente y sin ánimo de lucro con el único fin de ayudarte. Se paciente y agradecido.
-SOLOLINUX-
  #7 (permalink)  
Antiguo 19/08/2015, 19:38
 
Fecha de Ingreso: septiembre-2010
Mensajes: 1.853
Antigüedad: 13 años, 6 meses
Puntos: 6
Respuesta: Problemas para habilitar php-ldap en centos 6

lauser como actualizo centos 6.x a 6.7 ? debo de realizar un backup de mis archivos?
  #8 (permalink)  
Antiguo 19/08/2015, 23:20
Avatar de lauser
Moderator Unix/Linux
 
Fecha de Ingreso: julio-2013
Ubicación: Odessa (Ukrania)
Mensajes: 3.278
Antigüedad: 10 años, 8 meses
Puntos: 401
Respuesta: Problemas para habilitar php-ldap en centos 6

Aparte de los repos oficiales, presupongo que tienes los epel.
Si lo tienes todo correcto, debería de actualizar con:
Código BASH:
Ver original
  1. yum clean all
  2. yum update

6.5-->6.6-->6.7
__________________
Los usuarios que te responden, lo hacen altruistamente y sin ánimo de lucro con el único fin de ayudarte. Se paciente y agradecido.
-SOLOLINUX-
  #9 (permalink)  
Antiguo 20/08/2015, 15:04
 
Fecha de Ingreso: septiembre-2010
Mensajes: 1.853
Antigüedad: 13 años, 6 meses
Puntos: 6
Respuesta: Problemas para habilitar php-ldap en centos 6

y para un servidor con centos 5 , como seria el proceso para actualizarlo a centos 6.7?
  #10 (permalink)  
Antiguo 21/08/2015, 01:41
Avatar de lauser
Moderator Unix/Linux
 
Fecha de Ingreso: julio-2013
Ubicación: Odessa (Ukrania)
Mensajes: 3.278
Antigüedad: 10 años, 8 meses
Puntos: 401
Respuesta: Problemas para habilitar php-ldap en centos 6

La actualización de centos5.x a centos6.x, no es posible. Demasiados errores a corregir.

Te sugiero una migración segura.
__________________
Los usuarios que te responden, lo hacen altruistamente y sin ánimo de lucro con el único fin de ayudarte. Se paciente y agradecido.
-SOLOLINUX-

Etiquetas: centos, habilitar, php, servidor
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:54.