Foros del Web » Administración de Sistemas » Software para Servers »

Configurar subdominio para ficheros estáticos

Estas en el tema de Configurar subdominio para ficheros estáticos en el foro de Software para Servers en Foros del Web. Hola, me gustaría configurar esto para que todas las peticiones http de mis ficheros de imagen, css o js sean realizadas a través de un ...
  #1 (permalink)  
Antiguo 30/01/2013, 05:14
Avatar de Mikimoto74  
Fecha de Ingreso: enero-2005
Mensajes: 88
Antigüedad: 16 años, 6 meses
Puntos: 2
Configurar subdominio para ficheros estáticos

Hola,

me gustaría configurar esto para que todas las peticiones http de mis ficheros de imagen, css o js sean realizadas a través de un subdominio. Según tengo entendido, para evitar que las cookies del dominio sean enviadas dentro de las peticiones http para obtener estos recursos, y ahorrar ancho de banda y tiempo de carga.

Entonces, he creado un subdominio en mi proveedor de hosting de la siguiente manera:

static.midominio.com

Lo he dejado con el valor por defecto: que apunte al mismo directorio raíz de mis documentos, porque los recursos estáticos están ahí, y de momento no había pensado en reubicarlos:

images/
css/
scripts/

Estoy bastante verde en esto de servidores web. Así que el problema al que me enfrento ahora es el siguiente: Antes de realizar cambios en el fichero de configuración de mi web para cambiar la url desde donde buscar imágenes, los css y scripts, he hecho una prueba de intentar obtenerlos con el nuevo subdominio directamente desde la barra de navegación. O sea

Cambiando
www.midominio.com/images/xl/imgxxx.jpg
por
static.midominio.com/images/xl/imgxxx.jpg

Pero me realiza la siguiente reescritura de URL, que genera un error 404:

www.midominio.com/static/images/xl/imgxxx.jpg

Qué podría hacer para solucionarlo? Alguna regla con el mod_rewrite?
  #2 (permalink)  
Antiguo 04/02/2013, 16:38
 
Fecha de Ingreso: octubre-2010
Mensajes: 374
Antigüedad: 10 años, 9 meses
Puntos: 34
Respuesta: Configurar subdominio para ficheros estáticos

Umm es raro tal vez mala configuraciòn del Subdominio, tal vez de las DNS, tal vez tengas un cname de *.dominio.com y todo rediriga a www.. la verdad no se que decirte, danos más detalles, que panel de control usas ? cpanel, plesk etc

Intenta hacer el subdominio static fuera del public_html.

Mueve el contenido static a la carpeta y luego intenta otra vez, y si eso mira el error_log a ver que te dice.
__________________
Administrador de Servidores -> yo[arroba]skamasle[puntito]com
| Debian | Centos |
| Solución de Problemas | Seguridad | Instalaciones y Configuraciones | Soluciones Anti-DDOS

Etiquetas: apache, estatica, estatico, htaccess, mod_rewrite, servidores-web, subdominio, subdominios
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 14:02.