Foros del Web » Administración de Sistemas » Apache »

Apache webroot en home de usuario - error 403

Estas en el tema de Apache webroot en home de usuario - error 403 en el foro de Apache en Foros del Web. Hola a todos. Estoy intentando mover mi directorio home de apache (/var/www/html) al directorio home de mi usuario (/home/lair). modifiqué los archivos de configuración de ...
  #1 (permalink)  
Antiguo 22/08/2016, 11:13
Avatar de lair  
Fecha de Ingreso: enero-2009
Ubicación: header('Location: Morelia");
Mensajes: 1.052
Antigüedad: 15 años, 3 meses
Puntos: 46
Apache webroot en home de usuario - error 403

Hola a todos.

Estoy intentando mover mi directorio home de apache (/var/www/html) al directorio home de mi usuario (/home/lair). modifiqué los archivos de configuración de apache para que apuntaran a esa ruta, quedando así:

/etc/httpd/conf/httpd.conf
Cita:
DocumentRoot "/home/lair/Public"
/etc/httpd/conf.d/localhost.conf
Cita:
<VirtualHost *:80>
ServerName localhost
#Redirect permanent / https://localhost
DocumentRoot /home/lair/Public/localhost/html

ErrorLog /home/lair/Public/localhost/log/error.log
CustomLog /home/lair/Public/localhost/log/access.log combined
</VirtualHost>
<VirtualHost *:443>
DocumentRoot /home/lair/Public/localhost/html
ServerName localhost

ErrorLog /home/lair/Public/localhost/log/error.ssl.log
CustomLog /home/lair/Public/localhost/log/access.ssl.log combined


SSLEngine on
SSLCertificateFile /home/lair/Public/localhost/certificate/localhost.crt
SSLCertificateKeyFile /home/lair/Public/localhost/certificate/localhost.key

<Directory /home/lair/Public/localhost/html>
AllowOverride All
</Directory>

ServerSignature Off
</VirtualHost>
Los permisos que estoy asignando son:
chmod 775 y chown lair:apache


Asigné permisos a home así:
[root@localhost /]# ll
Cita:
drwxrwxr-x. 3 lair apache 17 Aug 12 2015 home
dentro de home:
[root@localhost /]# ll /home/
Cita:
drwxrwxr-x. 71 lair apache 4096 Aug 22 11:54 lair
dentro de lair así:
[root@localhost /]# ll /home/lair/
Cita:
drwxrwxr-x. 10 lair apache 4096 Aug 22 10:38 Public
y dentro de public se encuentra cada desarrollo bajo el siguiente esquema:
Cita:
drwxrwxr-x 5 lair apache 45 Aug 22 10:17 localhost
[root@localhost /]# ll /home/lair/Public/localhost/
Cita:
drwxrwxr-x 2 lair apache 46 Aug 22 10:17 certificate
drwxrwxr-x 11 lair apache 4096 Aug 22 10:17 html
drwxrwxr-x 2 lair apache 129 Aug 22 10:17 log
Cuando entro al sitio (localhost o cualquier otro host) me muestra la página por defecto de CentOS (no index)
https://www.dropbox.com/s/wv47dh6fyh...11-15.png?dl=0


En el log del vhost veo qu la petición "/" marca un 403:
Cita:
::1 - - [22/Aug/2016:11:58:57 -0500] "GET / HTTP/1.1" 403 4897 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36"
::1 - - [22/Aug/2016:11:58:57 -0500] "GET /noindex/css/bootstrap.min.css HTTP/1.1" 304 - "http://localhost/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36"
::1 - - [22/Aug/2016:11:58:57 -0500] "GET /noindex/css/open-sans.css HTTP/1.1" 304 - "http://localhost/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36"
::1 - - [22/Aug/2016:11:58:57 -0500] "GET /images/apache_pb.gif HTTP/1.1" 304 - "http://localhost/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36"
::1 - - [22/Aug/2016:11:58:57 -0500] "GET /images/poweredby.png HTTP/1.1" 304 - "http://localhost/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36"
::1 - - [22/Aug/2016:11:58:57 -0500] "GET /favicon.ico HTTP/1.1" 403 213 "http://localhost/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36"
y si intento acceder a alguna carpeta tambien retorna un 403
Cita:
[root@localhost html]# pwd
/home/lair/Public/localhost/html
[root@localhost html]# ll
total 1480
drwxrwxr-x 3 lair apache 4096 Aug 22 10:17 composer
drwxrwxr-x 4 lair apache 51 Aug 22 10:17 htaccess
-rwxrwxr-x 1 lair apache 155 Aug 22 10:17 iframe.html
-rwxrwxr-x 1 lair apache 19 Aug 22 10:17 index.php
drwxrwxr-x 3 lair apache 4096 Aug 22 10:17 migraciones
drwxrwxr-x 3 lair apache 76 Aug 22 10:17 stream
drwxrwxr-x 2 lair apache 75 Aug 22 10:17 upload
https://www.dropbox.com/s/vkowdlk7s1...14-08.png?dl=0


¿Hay algo que se me esté pasando o adicional que necesito hacer?

gracias por tomarse el tiempo, saludos.
  #2 (permalink)  
Antiguo 04/09/2016, 10:09
 
Fecha de Ingreso: febrero-2008
Ubicación: Caravana
Mensajes: 455
Antigüedad: 16 años, 2 meses
Puntos: 30
Respuesta: Apache webroot en home de usuario - error 403

No es mi fuerte, pero ... el usuario de apache no es www-data?
__________________
Movilandroid la tecnología móvil para android.
  #3 (permalink)  
Antiguo 05/09/2016, 10:25
Avatar de lair  
Fecha de Ingreso: enero-2009
Ubicación: header('Location: Morelia");
Mensajes: 1.052
Antigüedad: 15 años, 3 meses
Puntos: 46
Respuesta: Apache webroot en home de usuario - error 403

Cita:
Iniciado por lagardel Ver Mensaje
No es mi fuerte, pero ... el usuario de apache no es www-data?
Es www-data en distribuciones Ubuntu/Debian para las basadas en RH (Fedora/CentOS) es apache. gracias por tu comentario.

Saludos.

Etiquetas: centos, home, virtualhost
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 14:23.