Foros del Web » Administración de Sistemas » Apache »

No me funciona el redireccionamiento

Estas en el tema de No me funciona el redireccionamiento en el foro de Apache en Foros del Web. Buenas, Si alguien puede echarme una mano, le estaré muy agradecida. No hay manera de armar una url amigable. En el fichero htaccess tengo lo ...
  #1 (permalink)  
Antiguo 10/07/2013, 16:52
 
Fecha de Ingreso: enero-2002
Ubicación: Sabadell
Mensajes: 564
Antigüedad: 19 años, 4 meses
Puntos: 4
No me funciona el redireccionamiento

Buenas,
Si alguien puede echarme una mano, le estaré muy agradecida.
No hay manera de armar una url amigable.

En el fichero htaccess tengo lo siguiente:
Código Apache:
Ver original
  1. RewriteEngine On
  2. Options +SymLinksIfOwnerMatch
  3. RewriteRule ^oportunidades/(.*)$        oportunidades.php?lng=$1 [L]

El fichero htacces lo tengo en http://localhost/finc

Y la página donde tengo el link y la página donde apunta están en http://localhost/finc/es

El link es:
Código HTML:
Ver original
  1. <a href=oportunidades/es>Ver más</a>

El error es que no encuentra la página porqué va a parar a
http://localhost/finc/es/oportunidades
cuando lo que yo quiero es
http://localhost/finc/es/oportunidades.php?lng=es

Muchas gracias
__________________
Qué fácil cuando lo sabes y qué difícil cuando no

Etiquetas: htaccess, php, redireccionamiento, url
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:15.