Foros del Web » Programación para mayores de 30 ;) » Bases de Datos General » PostgreSQL »

Que versión usar

Estas en el tema de Que versión usar en el foro de PostgreSQL en Foros del Web. Hola amigos, tengo un viejo servidor: PIV un solo procesador 1Gb de ram DD: 80 gb en el he instalado debian 8.1 la idea es ...
  #1 (permalink)  
Antiguo 07/08/2015, 16:49
 
Fecha de Ingreso: julio-2006
Mensajes: 55
Antigüedad: 17 años, 8 meses
Puntos: 0
Que versión usar

Hola amigos, tengo un viejo servidor:
PIV un solo procesador
1Gb de ram
DD: 80 gb
en el he instalado debian 8.1 la idea es instalar postgres para alli servir datos a una aplicacion pequeña, no muchos usuarios (menos de 50 consecutivos)no muchos registros,
la mayor tabla estara por el orden de los 100.000 registros y su crecimiento estara por el orden de los 2000 registros anuales, soy bastante nuevo en postgres(novato novato) por eso mi pregunta con el hardware que tengo, que versión usar, en alguna parte he leido que la version 9.1 es mas rapida y menos exigente, lo cual me parece logico porque las versiones viejas se desarrollaron para hardware de la epoca ...
que me recomiendan y como instalar ya que el simple
apt-get install postgres-9.1 ---- ó 9.4 no funciona


Saludos ........
  #2 (permalink)  
Antiguo 07/08/2015, 22:58
Avatar de _Lucifer_  
Fecha de Ingreso: junio-2006
Mensajes: 1.662
Antigüedad: 17 años, 10 meses
Puntos: 28
Respuesta: Que versión usar

julioctorresg

¿Qué error muestra? generalmente con ejecutar apt-get install postgresql lo instala sin mayores problemas (debes ejecutarlo como root).

O si quieres poner la versión específica: apt-get install postgresql-9.4 que hasta donde sé está en los repos de debian.

Saludos.
__________________
Si crees que no tiene sentido, etonces probablemente lo tenga... :arriba:
  #3 (permalink)  
Antiguo 08/08/2015, 06:42
 
Fecha de Ingreso: julio-2006
Mensajes: 55
Antigüedad: 17 años, 8 meses
Puntos: 0
Respuesta: Que versión usar

hola, lanzo la siguiente instrucción como root

apt-get install postgres-9.4

manda el siguiente error ...

no se pudo encontrar ningun paquete con la expresión regular postgres-9.4

Saludos
  #4 (permalink)  
Antiguo 08/08/2015, 14:52
 
Fecha de Ingreso: julio-2006
Mensajes: 55
Antigüedad: 17 años, 8 meses
Puntos: 0
Respuesta: Que versión usar

Resuelta la instalación de postgres 9.4 sin embargo me gustaria volver a la pregunta original, dadas las caracteristicas(limitaciones) de hardware que conviene mas version 9.1 o 9.4 ? gracias
  #5 (permalink)  
Antiguo 12/08/2015, 08:16
Avatar de _Lucifer_  
Fecha de Ingreso: junio-2006
Mensajes: 1.662
Antigüedad: 17 años, 10 meses
Puntos: 28
Respuesta: Que versión usar

Te recomiendo usar la que trae la distro por defecto, en este caso la 9.4. Además Postgres parece ir optimizando tras cada versión (aún no pruebo en forma la 9.4 pues todos nuestros servidores de producción usan la 9.3 aún)

Saludos.
__________________
Si crees que no tiene sentido, etonces probablemente lo tenga... :arriba:

Etiquetas: postgres, tabla, usar
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 18:59.