Foros del Web » Programando para Internet » PHP » Zend »

ZF 2 en PHP 5.0.4

Estas en el tema de ZF 2 en PHP 5.0.4 en el foro de Zend en Foros del Web. He tenido problemas al ejecutar un servidor basado en PHP y ZF 2 en un Apache Server con PHP 5.0.4, ¿debería funcionar u opto por ...
  #1 (permalink)  
Antiguo 18/12/2013, 17:55
Avatar de JairLizcano  
Fecha de Ingreso: junio-2008
Ubicación: Santander, Colombia
Mensajes: 608
Antigüedad: 16 años, 1 mes
Puntos: 53
Pregunta ZF 2 en PHP 5.0.4

He tenido problemas al ejecutar un servidor basado en PHP y ZF 2 en un Apache Server con PHP 5.0.4, ¿debería funcionar u opto por actualizarlo?

Conozco muy bien los requisitos de ZF 2: http://manual.zfdes.com/2/es/ref/req...l#.UrI1O_TuKWY

Pero me gustaría intentarlo de otra forma.
__________________
Programar dejó de ser una profesión acusada en la oscuridad y disfrutada fríamente... para convertirse en un arte.
  #2 (permalink)  
Antiguo 18/12/2013, 18:18
Avatar de masterpuppet
Software Craftsman
 
Fecha de Ingreso: enero-2008
Ubicación: Montevideo, Uruguay
Mensajes: 3.550
Antigüedad: 16 años, 5 meses
Puntos: 845
Respuesta: ZF 2 en PHP 5.0.4

La version minima para zf2 es PHP 5.3.3, de todas formas no comprendo muy bien la pregunta teniendo en cuenta que el fw tiene requisitos minimos.

Saludos.
__________________
http://es.phptherightway.com/
thats us riders :)
  #3 (permalink)  
Antiguo 18/12/2013, 20:39
Avatar de JairLizcano  
Fecha de Ingreso: junio-2008
Ubicación: Santander, Colombia
Mensajes: 608
Antigüedad: 16 años, 1 mes
Puntos: 53
Pregunta Respuesta: ZF 2 en PHP 5.0.4

¿La versión mínima de ZF 2 no es PHP 5.1.4?

Aclaro que en el servidor la versión que se maneja es 5.0.4.
__________________
Programar dejó de ser una profesión acusada en la oscuridad y disfrutada fríamente... para convertirse en un arte.
  #4 (permalink)  
Antiguo 18/12/2013, 21:40
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.567
Antigüedad: 18 años, 1 mes
Puntos: 2135
Respuesta: ZF 2 en PHP 5.0.4

La versión 5.0.4 es muy vieja, como te dice masterpuppet, debes de tener 5.3.3 mínimo.
  #5 (permalink)  
Antiguo 18/12/2013, 21:41
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.567
Antigüedad: 18 años, 1 mes
Puntos: 2135
Respuesta: ZF 2 en PHP 5.0.4

Aquí puedes ver lo mínimo...

http://framework.zend.com/manual/2.2.../overview.html
  #6 (permalink)  
Antiguo 18/12/2013, 23:27
Avatar de JairLizcano  
Fecha de Ingreso: junio-2008
Ubicación: Santander, Colombia
Mensajes: 608
Antigüedad: 16 años, 1 mes
Puntos: 53
Respuesta: ZF 2 en PHP 5.0.4

Realmente me estaba fiando también de esta información: http://framework.zend.com/manual/1.1...ements.version

Hasta mañana podré realmente probar paso a paso la versión. Pero me gustaría llegar con algo más de seguridad al hacer pruebas en el servidor...
__________________
Programar dejó de ser una profesión acusada en la oscuridad y disfrutada fríamente... para convertirse en un arte.
  #7 (permalink)  
Antiguo 19/12/2013, 03:19
Avatar de masterpuppet
Software Craftsman
 
Fecha de Ingreso: enero-2008
Ubicación: Montevideo, Uruguay
Mensajes: 3.550
Antigüedad: 16 años, 5 meses
Puntos: 845
Respuesta: ZF 2 en PHP 5.0.4

Lo que muestras es para Zend 1.12, https://github.com/zendframework/zf2...m-requirements
__________________
http://es.phptherightway.com/
thats us riders :)

Etiquetas: php
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:46.